Search Issue Tracker

Fixed in Unity 2018.3

Votes

2

Found in

2018.1.0b12

Issue ID

1017374

Regression

No

[LWRP] WebGL does not work correctly

Graphics - General

-

-

Priority: 3Not yet prioritized for a release

-

Severity: 2Core functionality majorly impacted

Scene is not rendered in the WebGL when built with LightWeight RP Template

Steps to Reproduce:
1. Create new Project > Select LWRP Template
2. Switch platform to WebGL
3. Make a build and run

Observe nothing is rendered except skybox and UI elements (if any).

Reproducible with:
2018.3.0a3,2018.2.0b9, 2018.1.0b13, 2018.1.0b12, 2018.1.0b11, 2018.1.0b10, 2018.1.0b9, 2018.1.0b8, 2018.1.0b7, 2018.1.0b6, 2018.1.0b5

Note: LWRP Project Template is introduced in 2018.1.0b5

Environment:
Windows 10, Windows7, Mac 10.13, Mac 10.12.

Comments (7)

  1. 1b030458f5bc1e4775186437edf956a9?d=mm

    Roycon

    Nov 14, 2018 19:44

    Still not fixed in 2018.3.0b9

  2. Ed32d4b9d66ef4417cdc70e916e8b61f?d=mm

    HackTheREALITY

    Oct 03, 2018 06:59

    Still does not work on unity 2018.3 beta

  3. B47afabd910858795cbee984a4210bb6?d=mm

    iBicha

    Sep 19, 2018 21:14

    This issue is still not fixed in 2018.3.0b1

  4. A4bf189e09ee2e6f07da6eac9342a14a?d=mm

    jterry

    Jun 26, 2018 12:25

    Still there in Unity 2018.2.0b9

  5. E7450742b0fb9c4c69426524978c3043?d=mm

    Jokerminator

    May 08, 2018 16:58

    Still there in 2018.1f2.

  6. C70ab73e54f103f652d46395cc5fe6f3?d=mm

    z77

    May 05, 2018 13:01

    Same here. Macbook PRO, Chrome Version 66.0.3359.139 (Official Build) (64-bit).
    Unity-WebGL just shows blue screen.

  7. E7450742b0fb9c4c69426524978c3043?d=mm

    Jokerminator

    Mar 30, 2018 17:19

    I can confirm that the lightweight scriptable render pipeline doesn't render any objects with WebGL 2 ( OpenGLES3 ) in beta 12 and 13.

    Windows(10) and Android (8.1) builds work fine, even with post-processing v2 and HDR.

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.