Search Issue Tracker

Not Reproducible

Votes

4

Found in

Issue ID

1058774

Regression

No

[LWRP] All Meshes Invisible in Android Build LWRP

XR

-

SRP Repo: Issue #1316

All Meshes Invisible in Android Build LWRP

I can't for the life of me get any meshes to render at all in my Android build. It runs fine in-editor and it runs fine built in 2017.3 with no scriptable render pipeline.
I'm using 2018.1.0f2
pipelines.core and pipelines.lightweight imported through package manager.
I've tried lightweight standard PBR and simple lighting, I've tried lightweight unlit, and I've tried a few of my shader graph shaders. No meshes at all render on android (Galaxy Note 4). UI and sprite renderers render just fine. And again it works properly in the editor.
I was getting errors when I tried to run "Generate Shader Includes" but then I went into appdata and unchecked read only on all the pipeline files, and the error stopped. When I run a build I see it generating all the shader variants for the lightweight pipeline. But still, no meshes render on my phone.

Edit: Actully. Lightweight/Standard Unlit DOES render on my phone, but only when Surface Type is set to Transparent. It won't render when set to Opaque.

Edit 2: Interestingly if I change the render queue to transparent on any of these materials they render, albeit as if they were transparent (you can see through them)

Comments (2)

  1. 03c8463335f6399f1830fe85c0bd7420?d=mm

    AndreDelarge

    Aug 14, 2019 12:20

    Having same issue

    And ive got decision
    Go to you LightweightRenderPipelineAsset and disable Advanced->SRP Batcher

  2. 67d1690a70c4c2e1f706826fbae6dbef?d=mm

    itdikey

    Aug 14, 2019 11:20

    Having the same issue

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.