Search Issue Tracker

Not Reproducible



Found in


Issue ID




[Linux Editor] Assertion failed: Reentered BeginCurrentContext after drag-and-dropping a material to the scene



Steps to reproduce:
1. Create a new project
2. In the scene, add a plane and a cube
3. Create a new material, change its color to red
4. Drag-and-drop the newly created material on the plane in Scene View

Result: console outputs an error
Assertion failed: Reentered BeginCurrentContext
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Reproduced on: 2017.1.0f1
Did not reproduce on: 5.6.2f1

Note: the issue does not always seem to reproduce, but I was able to reproduce it on the second attempt by following the video guide "unity2017.1.0xf1-assert-begincurrentcontext-1.ogv"

Comments (17)

  1. Pino_B

    Jan 30, 2018 06:19

    Same issue here using Unity 2017.3.0p2 under Debian stretch 64 Bit.

  2. irakliy01

    Jan 07, 2018 18:56

    Same on 2017.3.0f1 (Ubuntu 17.10)

  3. Romanovzky

    Oct 23, 2017 08:23

    Same to me, appeared just after I created a new scene and added an image as a canvas child. 2017.2.0f3 (Arch, AMD R7 1700x, Nvidia 1080)

  4. aigoia

    Oct 09, 2017 08:33

    i have a same error too

  5. roired-xsoto

    Sep 17, 2017 18:15

    Still There on 2017.1.1xf1, and with a 2D project adding sprite
    (Ubuntu 17.04, AMD CPU, AMDGPU-PRO driver)

  6. thedude22

    Aug 29, 2017 20:36

    Same error for me on both 2017.1 and 2017.2 beta.

    Running the aur build in Arch Linux.

    Error doesn't seem to do anything.

  7. Alderin

    Aug 23, 2017 00:24

    I can confirm existence on 2017.1.0xf3Linux.

    It shows up in my current project pretty much daily, but I am not manipulating materials at this point in my project. I agree with the minor severity, as everything seems to work fine otherwise.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.