Search Issue Tracker

Not Reproducible

Votes

19

Found in

2017.1.0xf1

Issue ID

926343

Regression

Yes

[Linux Editor] Assertion failed: Reentered BeginCurrentContext after drag-and-dropping a material to the scene

Linux

-

Steps to reproduce:
1. Create a new project
2. In the scene, add a plane and a cube
3. Create a new material, change its color to red
4. Drag-and-drop the newly created material on the plane in Scene View

Result: console outputs an error
Assertion failed: Reentered BeginCurrentContext
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

Reproduced on: 2017.1.0f1
Did not reproduce on: 5.6.2f1

Note: the issue does not always seem to reproduce, but I was able to reproduce it on the second attempt by following the video guide "unity2017.1.0xf1-assert-begincurrentcontext-1.ogv"

Comments (15)

  1. 2667db439af5a3dc661418aa759affcd?d=mm

    Advis91

    Sep 18, 2018 00:27

    I got the same bug report, but I accidently opened additional window (experimental -> look dev) which I couldn't close, so I happened to Window -> Layouts -> Reset factory settings to reset the layout.
    Now I don't get the error message and the material is applied a lot faster. I happened to install the editor today...

  2. 2667db439af5a3dc661418aa759affcd?d=mm

    Advis91

    Sep 17, 2018 23:18

    Just tried this in 2018.2.7f1 and dragging materials applied the color to the plane and cube.
    However because the screen updates very slowly, I could release the drag and move the mouse away, before it would try to apply the material.

  3. 3229b184dc8408ff33b4746756b1548d?d=mm

    OBI_Ron

    Jul 04, 2018 21:15

    Same here - Ubuntu 16.04 - 2018.1.5f1
    After creating a material and saving the scene, I re-open, and will get the error when selecting any object that has the material assigned.
    Console:
    Assertion failed: Reentered BeginCurrentContext
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

    However, after playing and stopping, the error goes away, and everything "appears" to work fine compiling.

  4. 9d6ef37b8f66014e198c1bc8f7c1978c?d=mm

    p0werew0p

    May 22, 2018 06:51

    Ubuntu 18.04
    Unity 2017.2.0b11
    the same problem, i can't put created material on terrain, and no Scene's materials in terrain's Inspector when Brush selected
    but all right if use material on new Cube

  5. A6456c0fedd32580f283d8eb2e71f707?d=mm

    whereiam114

    May 09, 2018 17:06

    i have same error on linuxmint too

  6. 837e11c6e16be6244bed66eaa9669dc3?d=mm

    Gomenasai

    Apr 18, 2018 22:13

    I have same problem. But this problem do nothing for my project. I mean, i don't have any bug or something in my project.

    Elementary OS. (Ubuntu)

  7. A377ee1f31cf652cf9dc681f35c900ce?d=mm

    AntMidd1977

    Apr 01, 2018 04:14

    I'm having same issue. Except mine won't run

  8. Efb690acd3bb5eeebe207f9cd61a8cf1?d=mm

    robi_combi

    Mar 21, 2018 21:12

    Yes, the same to me in version: 2018.1.0b8

    https://imgur.com/a/Odpny

    <blockquote class="imgur-embed-pub" lang="en" data-id="a/Odpny"><a href="//imgur.com/Odpny"></a></blockquote><script async src="//s.imgur.com/min/embed.js" charset="utf-8"></script>

  9. 2802eeba643df205e1ddc167edf88b11?d=mm

    Pino_B

    Jan 30, 2018 06:19

    Same issue here using Unity 2017.3.0p2 under Debian stretch 64 Bit.

  10. 7027292febe762999e6a6981119b9b7e?d=mm

    irakliy01

    Jan 07, 2018 18:56

    Same on 2017.3.0f1 (Ubuntu 17.10)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.