Search Issue Tracker

Fixed in 2018.2

Votes

10

Found in

2017.3.1p1

Issue ID

1006867

Regression

No

[iOS][TileMap] Tilemap.SetTile() does not set tiles on iOS platform

Mobile

-

Reproduction Steps:
1. Open User's project
2. Run "TestScene"
3. Notice Unity logo
4. Build and deploy to an iOS device
5. Notice that no Unity logo appears

Expected behaviour: TilemapSetTile() method behaves identically on all platforms.
Actual result: TilemapSetTile() does nothing on iOS platform

Reproduced on versions: Unity 2017.3.1p3, 2018.1.0b9
Did not reproduce on versions: Unity 2018.2.0a2
Reproduced on devices: iPhone 7 Plus iOS 10.3.2
Did not reproduce on Android device

Comments (6)

  1. 53c2817da24cdd35b38ccf400ada76c3?d=mm

    dagwoodland

    Apr 19, 2018 21:55

    This seems to be fixed in 2017.4.1f1, the tiles now appear. Tested on iPhone 6S iOS 11.2.6

  2. E74bbc08d6f0a3ff895ae5c00be21273?d=mm

    Hoofmaster

    Mar 22, 2018 22:24

    I tried it on 2018.1.0b11 and it looks to be fixed.

  3. E74bbc08d6f0a3ff895ae5c00be21273?d=mm

    Hoofmaster

    Mar 21, 2018 19:17

    Note the same issue also happens if you use "SetTiles". I also tried overriding the RefreshTile method, but it looks to be calling the base method internally.

  4. E74bbc08d6f0a3ff895ae5c00be21273?d=mm

    Hoofmaster

    Mar 21, 2018 19:16

    Has anyone found a workaround for this?

  5. C8b132e8b40b6f5df5eee2cfdb3d9dac?d=mm

    Jhsosa

    Mar 09, 2018 20:40

    Same problem here. Reproduced on iPhone 6s. Androind is fine (LG Stylo 2, ZTE ZMAX PRO)

  6. 2d6d0eff315f90730b4897382d2e5e12?d=mm

    bastiduong

    Mar 02, 2018 11:46

    I have the same issue.
    Reproduced on iPhone SE.

    On Android Devices, it works fine. (Sony Z3, HTC M9)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.