Search Issue Tracker

Fixed in 2017.3.0f3

Fixed in 2017.2

Votes

7

Found in

2017.2.0b7

Issue ID

941148

Regression

Yes

[iOS][IL2CPP] UnityLinker.exe fails to run when building for iOS platform

IL2CPP

-

To reproduce:
1. Open attached project
2. Build for iOS platform

Expected: Unity builds project successfully.
Actual: Build fails because UnityLinker didn't run properly.

Reproduced with: 2017.2.0b2, 2017.2.0b7, 2017.3.0a4
Not reproducible with: 2017.1.0p3, 2017.2.0b1
Regression since 2017.2.0b2

Fixed in: 2017.3.0a7
Backported to 2017.2.0b11

Comments (20)

  1. 22b26b82f404d48da2b5086ea90fecea?d=mm

    networm

    Aug 28, 2020 00:28

    It seems that you are using Windows 7. And the problem is that you didn't install the latest .Net Framework.
    I installed .Net Framework 4.8 on Windows 7 and then Unity build Android IL2CPP successfully.

    Environments:

    - Windows 7
    - .Net Framework 4.8
    - Unity 2018.4.25f1

  2. 9b70697d042c16fd60210a0166944817?d=mm

    ISTA33

    Aug 10, 2020 02:27

    The New Solution Here Veryyyy easyyyy

    https://www.youtube.com/watch?v=3obkNiuInU0

  3. 9b70697d042c16fd60210a0166944817?d=mm

    ISTA33

    Aug 10, 2020 01:43

    **** Here Is The Solution That Everybody Loking For it :

    https://www.youtube.com/watch?v=zYIGZjGN05Q

  4. D47cb464e356114137f505c29ce16138?d=mm

    JollyByte

    Dec 07, 2019 07:23

    I know this is old but I came across the same issue in version 2019.3.0f1 as I found my solution:

    The ASP.NET version built in windows. That cannot be upgraded and my windows build was outdated. I had to updated to Windows 10 Pro 1909 which has the latest ASP.NET framework version. Hope this helps some of you.

    https://www.microsoft.com/en-us/software-download/windows10

  5. 620be4e1f279709711ba4655d7463c8b?d=mm

    mzr_developer

    Jul 22, 2019 01:24

    We have the same issue in Unity 2019.1.10f1.

  6. A98cdbb0b5d7a2d72735e501854d103a?d=mm

    sangshuai

    Mar 20, 2019 09:43

    Is that solved now

  7. A2f6df8ded8c42cc86fc8b0e913207c9?d=mm

    milad440550

    Aug 28, 2018 12:37

    It works if you delete, by just deleting link.xml file, but I need the XML file. -_-

  8. A066d2778744ba828497a946077603c9?d=mm

    zcwfeng

    May 28, 2018 10:17

    1.Failed running /Applications/Unity/Unity.app/Contents/il2cpp/build/UnityLinker.exe --api=NET_2_0_Subset
    2.Exception: /Applications/Unity/Unity.app/Contents/il2cpp/build/UnityLinker.exe did not run properly!
    3.Build completed with a result of 'Failed'
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)
    4.UnityEditor.BuildPlayerWindow+BuildMethodException: 4 errors
    at UnityEditor.BuildPlayerWindow+DefaultBuildMethods.BuildPlayer (BuildPlayerOptions options) [0x00207] in /Users/builduser/buildslave/unity/build/Editor/Mono/BuildPlayerWindowBuildMethods.cs:172
    at UnityEditor.BuildPlayerWindow.CallBuildMethods (Boolean askForBuildLocation, BuildOptions defaultBuildOptions) [0x00050] in /Users/builduser/buildslave/unity/build/Editor/Mono/BuildPlayerWindowBuildMethods.cs:83
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

    No one can solve it ??? I can only see the problems in the Problems List but no one to solve it????

  9. 7ba24de5629a1760ede4fbdbeae3d666?d=mm

    Hyperlink_Unity3D

    Mar 22, 2018 06:06

    I was facing same issue when I upgrade Unity from 2017.1 to 2017.3.0f3.
    You can handle this issue by deleting library folder from your project directory.
    It worked in my case, hope to work in yours :)

  10. 7ba24de5629a1760ede4fbdbeae3d666?d=mm

    Hyperlink_Unity3D

    Mar 22, 2018 06:05

    I was facing same issue when I upgrade Unity from 2017.1 to 2017.3.0f3.
    You can handle this issue by deleting library folder from your project directory.
    It worked in my, hope to work in yours :)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.