Search Issue Tracker

Fixed in 4.5.5

Votes

23

Found in

4.5.0f6

Issue ID

616918

Regression

Yes

[iOS] "Application.Integrate Assets in Background" is taking up more time

iOS

-

Build and run project for iOS and check the time of Loading.UpdatePreloading->Application.Integrate Assets in the Unity profiler. Notice that the time is longer, compared to older versions of Unity

Comments (19)

  1. F55dc43c7d65497110d1ab43d5b2d318?d=mm

    OanhDvan

    Nov 10, 2018 13:18

    This problem still exists on version 2018.2.14f1 @@

  2. Fc9f2751a3b72df7e5da9c14c529a541?d=mm

    HalversonS

    Jul 31, 2017 12:19

    This is happening again in 2017.1. 60% of the time when the first scene load occurs. Pauses for 20 seconds. Hangs up at EarlyUpdate.UpdatePreloading.... Just updated from 5.6.0f3 where this was never happening.

  3. 0442dcfdf90dd32db67aa4254d24e8a8?d=mm

    trueDemetri

    May 17, 2017 11:50

    Problem is still here in Unity 5.5.2

  4. 2b9e45bc6070fb6c869bad3d66b1b31e?d=mm

    SBArtoons

    Jan 28, 2017 05:57

    I am still experiencing this problem with 5.4.3f1.When is this going to be fixed in Android and iOS.

  5. 5f2c52e2a568cafdf2d0cd5b1da415a1?d=mm

    muheydari

    Nov 09, 2016 19:44

    My game is suffering this issue in unity 5.3.4f1.

  6. E3047f7e998fb784a90618a5b01f0ac9?d=mm

    tayl0r

    Apr 08, 2016 19:46

    Also getting this in Android on Unity 5.2.2p4. 330 ms!

  7. Fffc1f462d8730d867102c0827af3511?d=mm

    scottlaforge

    Mar 14, 2016 19:02

    I'm experiencing this in 5.2.3 as well. I seen in other posts that the issue is fixed "by design." Can someone inform me of how I can correct these in my design?

  8. A7f92586f28c1263b3dd634d45752332?d=mm

    Wrymnn

    Feb 29, 2016 17:10

    Problem still occurs in 5.3.2. That is really making huge spikes. Why did you mark it as fixed?!

  9. 7694f641a5c5c72d8ce8259b59322684?d=mm

    MooseMouse

    Feb 11, 2016 16:28

    I am still experiencing this problem with 5.3.2p3

  10. A4934a53a13c94af812e61ff4c982b89?d=mm

    LacunaCorp

    Jan 12, 2016 19:30

    This is not fixed. Still persists in 5.2+ and is causing 2200ms spike for us.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.