Search Issue Tracker

Fixed in 1.1.0-pre.6

Votes

14

Found in [Package]

1.0.0

Issue ID

1260625

Regression

No

[Input System] Player Input Manager's Join Action is not triggered when using a referenced Input Action

Package: Input System

-

Reproduction steps:
1. Open the attached project ("case_1260625-JoinAction.zip")
2. Open the repro scene ("MainMenu")
3. Enter Play Mode
4. Press "Play Game", then "Level 1" buttons
5. Click on "Gamepad "A" simulation" button, or press "A" button on any connected controller

Expected result: Join Action is triggered
Actual result: Join Action is not triggered

Reproducible with: 2019.4.8f1, 2020.1.2f1, 2020.2.0a20
Couldn't test with 2018.4 (minimal package version not supported)
Reproducible with package versions: 1.0.0-preview.7, 1.0.0
Couldn't test with package versions below 1.0.0-preview.7 (project errors after downgrade)

Note: Disabling "Use Reference" in "GAME MANAGER" object's Player Input Manager component and setting it the action type manually fixes the issue

  1. Resolution Note (fix version 1.1.0-pre.6):

    Fixed in Input System 1.1.0-pre.6 available for 2019.4.0f1 and up

Comments (7)

  1. Not_Tryston

    Sep 23, 2021 19:44

    A short-term fix, make sure you have no control schemes. It worked for me when I removed mine.

  2. fmoo

    Aug 18, 2021 01:11

    Yeah, anyone have any workarounds? this is pretty rough. :(

  3. DomenickD3

    Jan 27, 2021 02:23

    Noting that I ran into this today. It would be nice if "use reference" worked properly.

  4. RR7

    Oct 21, 2020 19:16

    i confirm the *second* player onwards is the problem, and that if the first player auto joins it appears none of them work.

  5. huulong

    Oct 21, 2020 12:06

    The exact issue I had in my projects was: *second* join action not taken into account when using referenced input action. The first join action works normally.

    However, when a Player Input component is already present in the scene, it counts as the first player to join so any join action from here will fail. I guess the attached project had that setup. But if you try to repro from scratch, make sure to try to join multiple times (e.g. plug multiple gamepads with join action ref corresponding to Start and press Start on each gamepad).

    I may add more details on this thread: https://forum.unity.com/threads/player-input-manager-join-action-not-working.916880/

  6. RR7

    Oct 20, 2020 20:16

    okay look, maybe this doesn't seem very important, but its a feature, in a released package, that actually doesn't work. it doesn't do what it says it does and is supposed to do. it's not listed as a fix in the 1.1 preview so i'm assuming its not fixed yet. can you fix it please? i'm waiting a long time now to use this new input system.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.