Search Issue Tracker

Fixed in 1.1.0-pre.5



Found in [Package]


Issue ID




[Input System] Multi Tap Interaction doesn't get triggered when there are 2 or more Bindings in the active Control Scheme

Package: Input System


How to reproduce:
1. Open the attached "1267805 repro" project
2. Open the "SampleScene" Scene from Assets > Scenes
3. Enter Play Mode
4. Double-tap the "Space" key on the keyboard

Expected results: the Multi Tap Interaction gets triggered and a message is displayed in the Game window
Actual results: the Multi Tap Interaction doesn't get triggered

Reproducible with: 0.2.10-preview (2020.1.3f1), 0.9.6-preview (2020.1.3f1), 1.0.0 (2019.4.9f1, 2020.1.3f1. 2020.2.0a21)
Could not test with: 0.1.2-preview (2019.4.9f1, project errors)

-Switching to "DoubleTap_Working" Action Map fixes the issue
-The only difference between these Action Maps is that "DoubleTap_Broken Map" has 2 bindings on the Keyboard
-Removing any of the 2 Bindings resolves the issue and makes the Multi Tap Interaction work
-Only Bindings from present Control Schemes seem to reproduce the issue as can be seen in the "DoubleTap_Working" Action Map which has an additional Gamepad Binding which doesn't introduce the bug

  1. Resolution Note (fix version 1.1.0-pre.5):

Comments (3)

  1. peterconnected

    Sep 29, 2021 06:35

    The bug is still happening in 2020.3.19f1. It must have been un-fixed.

  2. teknochaos

    Jan 13, 2021 13:59

    I have exactly the same issue. I solved it by making "Action Type" pass through. I keep control type as button. Then I add interaction to binding. And it worked. Also I had a problem with Hold interaciton. My problem is that performed state is just happening once. I mean if i perform it once then it will never perform again. I solved it by making pass through, too. Then added interaction to binding, again.

  3. FileThirteen

    Sep 14, 2020 00:02

    I was going through and testing all the interactions myself and this is the one that doesn't work. Even when I remove all bindings except one I can only get the multi tap to trigger like 1/20th of the time I try. I see started and then cancelled like 95% of the time but occasionally I'll get a performed logged.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.