Search Issue Tracker

Fixed in 2019.3

Fixed in 2018.2, 2018.3, 2019.1

Votes

5

Found in

2018.3.0b10

2018.3.0b12

2019.1.0a12

Issue ID

1108917

Regression

Yes

Incompatible texture compression formats when building to different platforms in batchmode

Asset Import Pipeline

-

To reproduce:
1. Download users attached project "texture-settings-bug.zip", do not open the project on Editor
2. Delete Library folder
3. Open terminal and run:
/.../Unity.app/Contents/MacOS/Unity -batchmode -projectPath ~/.../texture-settings-bug -buildTarget OSXUniversal -executeMethod BuildScript.BuildmacOS -logFile ~/.../texture-settings-bug/logs/build-macos.log -quit
4. Check texture-settings-bug -buildTarget > Builds folder, macOS app is built
5. Without deleting Library folder run:
/.../Unity.app/Contents/MacOS/Unity -batchmode -projectPath ~/.../texture-settings-bug -buildTarget iOS -executeMethod BuildScript.BuildiOS -logFile ~/.../texture-settings-bug/logs/build-ios.log -quit
6. Observe the same folder as no Xcode project is built
7. Open texture-settings-bug > logs >build-ios.log and observe "DXT1 compressed textures are not supported when publishing to iPhone" error

Expected result: Xcode project is built
Actual result: getting "DXT1 compressed textures are not supported when publishing to iPhone" error in the log and the Xcode project is not built

Reproduced on:
2018.3.0b10 2018.3.1f1 2019.1.0a12

Doesn't reproduce:
2017.4.17f1 2018.2.0a1 2018.3.0b2 2018.3.0b9

Notes:
Doesn't build to macOS on 2018.1.9f2 2018.2.0b1 2018.2.20f1
iMac macOS 10.14

Comments (5)

  1. 3327e10f6925f254d84a493a166a2a95?d=mm

    ETGgames

    Jul 12, 2020 18:55

    Still get this issue with 2019.4.3f1 - DXT5 compressed textures are not supported when publishing to iPhone

    This happens for PSB imported assets.

  2. Badc14ded16ffc5ee3ca5b1648054fb5?d=mm

    lloydv

    Dec 20, 2019 05:43

    Occurring in 2019.3.0f3 in a new URP template project with the Lost Crypt package, after switching to iOS platform and attempting to build.

  3. 41cd443e42fb978f4da36b0498b729fb?d=mm

    clckwrk

    Oct 09, 2019 00:47

    Update: fixed this error. I had a material that was referencing a built-in asset.

  4. 41cd443e42fb978f4da36b0498b729fb?d=mm

    clckwrk

    Oct 08, 2019 22:55

    Still getting this error in 2019.3.0b6

  5. Af612385a6910fb9d89c5e6a957128db?d=mm

    Tom-Mensink

    Sep 19, 2019 09:41

    This is not solved in 2018.2f17

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.