Search Issue Tracker

Fixed in 2017.1.X



Found in


Issue ID




"In order to call GetTransformInfoExpectUpToDate..." error message appears while using Rigidbody Interpolate/Extrapolate



To reproduce:
1. Open users attached project.
2. Open scene DevScene.unity
3. Enter play mode
4. In scene view place GameObject Snowy_Complete on the top of red cube.

Expected result: No error is appearing
Actual result: "In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first." error message appears in the Console.

Note: When Rigidbody Interpolate is set to none errors don't appear.

Regression introduced in: 5.6.0b10
Reproducible with : 5.6.0f1, 5.6.0f3, 5.6.0p1, 2017.1.0a1
Not reproducible with: 5.5.0f3, 5.6.0b9, 2017.1.0b1


Fixed in: 2017.1.0a5 & 5.6.2p1

Comments (13)

  1. RussBartley2

    Aug 18, 2017 01:16

    please re-open voting, as this is not fixed in 5.6.2f1

  2. Danor

    Aug 10, 2017 02:07

    Present in 5.6.2.f1, fps falls from 58 to 38 with the error. Turning off Interpolate removes the error.

  3. limjongkook

    Jun 30, 2017 03:44

    Fixed in 5.6.2 p1 patch version.

  4. limjongkook

    Jun 29, 2017 02:10

    An error occurs again in 5.6.1p4.

  5. Unity-Nikos

    Jun 22, 2017 09:43

    Fixed in 5.6.2p1

  6. mushdevstudio

    Jun 20, 2017 01:29

    Can definitely confirm still happing in 5.6.1p4

    Why is Rigidbody Interpolation broken after version 5.5.4 ?

    Can anyone else please replicate this for me so I know i am not going nuts.

    Start a new project in Unity 5.6.1
    Create a 3D object cube
    Create a second 3D object cube
    Drag second cube down under the first cube and leave a gap
    Add a rigid body to the first cube
    Set RigidBody Interpolation to Interpolate
    Press play
    As soon as the first cube drops and makes contact with the second cube the console starts spamming "In order to call GetTransformInfoExpectUpToDate, RendererUpdateManager.UpdateAll must be called first."
    Which ends up having a severe impact on the performance of the game.

    Any ideas what can be done?

  7. DoenitZ

    Jun 19, 2017 22:02

    Ooops, sorry, false alarm, is STILL happening on 5.6.1p4...

    Who knows why I havent seen it before. But it just happened again...


    NOT FIXED on 5.6.1p4

  8. DoenitZ

    Jun 19, 2017 21:49

    Hi Everyone! This problem is NOT happening to me anymore con 5.6.1p4!
    Thank you!

    If I found it again, I will post it here. But for the moment, problem solved

  9. nazbee

    Jun 16, 2017 08:43

    Hope this is fixed for 5.6 branch soon

  10. mushdevstudio

    Jun 10, 2017 09:52

    It is so easy to reproduce.

    Unfortunately it is still happening in 5.6.1.p3
    5.5.3p4 is the last good version that Rigidbody Interpolation worked perfectly.

    Here is the easiest way for anybody to recreate issue using 5.6.1.p3:
    1) create new 3D cube game object
    2) add rigid body to cube - set interpolation to interpolate
    3) add collider to cube
    4) add another new 3D cube game object
    5) move second cube below first cube so the first one will fall onto second one
    6) press play
    7) if it does not produce the error the very first time then run again a few times.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.