Search Issue Tracker

Fixed in 2022.2.X

Fixed in 2020.3.X, 2021.3.X, 2022.1.X



Found in







Issue ID




First array element expansion is broken for arrays that use Custom Property Drawers

Inspector Framework


How to reproduce:
1. Open the attached project
2. Open the "SampleScene" and select "Input array" in the Hierarchy
3. Try to add bindings to the very first element of the array via the plus sign button
4. Observe that the array doesn't expand correctly

3. Select the "Custom" object and change the first element's field to "A" in the dropdown menu
4. Observe that the expansion is broken for the first array element only (might be broken for other too if checked on an older, non-fixed version)

Expected result: Arrays with custom property drawers always expand correctly
Actual result: The first first element of an array doesn't expand correctly if it uses custom property drawers

Reproduced in: 2022.2.0a8, 2022.1.0b12, 2021.2.16f1, 2021.1.28f1, 2020.3.31f1
Not reproducible with: 2020.2.0a13

  1. Resolution Note (fix version 2022.2):

    Fixed in 2022.2.0a13

  2. Resolution Note (fix version 2022.1):

    Fixed in 2022.1.0f1

  3. Resolution Note (fix version 2021.3):

    Fixed in: 2021.3.5f1

  4. Resolution Note (fix version 2020.3):

    Fixed in 2020.3.37f1

Comments (35)

  1. Swearsoft

    Jun 19, 2022 16:50

    Issue exists in 2021.3.4f1, but doesn't in 2021.3.3f1

  2. kwikdev

    Jun 19, 2022 01:56

    I'm seeing this in 2020.3.35f1

    One workaround is to add [NonReorderable] to the list.

    Draws correctly, but you can no longer re-order the items.

  3. kylaCpp

    Jun 18, 2022 07:35

    This question is bothering me

  4. Mlackey

    Jun 18, 2022 07:06

    Version 2020.3.35F1 - Experiencing this issue.

  5. Doorman

    Jun 16, 2022 07:53

    I also have this issue in 2021.3.4f1

  6. youminewecraft26

    Jun 15, 2022 17:09

    Can confirm this bug still exists in 2021.3.4f1

  7. Stadob

    Jun 15, 2022 07:30

    Seriously? Is this how "improving product" looks like? If you have systems which uses arrays custom property drawers in your project you have practially only two options: stop developmnet or rollback to 2021.3.0. Nice... Its been over month and it can be serious blocker for projects. Tell me again, why we should installing unity patches?

  8. GameChangerNow

    Jun 14, 2022 18:28

    Same error in 2021.3.4f1

  9. ermine123

    Jun 13, 2022 05:49

    It was working with Silicon LTS 2021.3.0f but broken again with Silicon LTS 2021.3.4f.

  10. lorddanger

    Jun 12, 2022 13:08

    Still not fixed in 2021.3.4f1

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.