Search Issue Tracker

Fixed in 2020.1

Fixed in 2019.3

Votes

19

Found in

2019.3.0b2

2019.3.0b4

2020.1.0a2

Issue ID

1187410

Regression

Yes

"Failed to load window layout" error window is shown when trying to open projects and specific regional format is chosen

Themes

-

Steps to reproduce:
1. Open Control Panel -> Region
2. Change Format to Turkish (Turkey)
3. Create a new project or open an existing one

Expected result: Project is opened
Actual result: "Failed to load window layout" error window is shown and only "Quit" button works

Reproducible with: 2019.3.0b2, 2019.3.0b6, 2020.1.0a2, 2020.1.0a8
Not reproducible with: 2017.4.33f1, 2018.4.10f1, 2019.2.9f1, 2019.3.0b1, 2020.1.0a1

Workaround: Change your operating system "Region & Language" settings to English (United States)

Notes:
- The bug is also reproducible with formats: Turkish (Cyprus), Azerbaijani (Latin, Azerbaijan), Azerbaijani (Cyrillic, Azerbaijan)
- "Revert Factory Settings" and "Load Default Layout" buttons just go back to the same "Failed to load window layout" error window

Comments (25)

  1. A9779c672bbe0e9bdc1ce5cab7d1bd4b?d=mm

    maclark86

    Sep 27, 2020 07:36

    also having the issue just creating a new project and opening it in in 2020.1.5f1

  2. 4dd85f177d19395262c4cc22a4d0cd2c?d=mm

    POCHY

    Sep 19, 2020 13:16

    I can not leave the link of the video because this page does not allow me.

  3. 4dd85f177d19395262c4cc22a4d0cd2c?d=mm

    POCHY

    Sep 19, 2020 13:16

    No Le Puedo Dejar El Link Del Video Porque esta Pagina No me La permite.

  4. 4dd85f177d19395262c4cc22a4d0cd2c?d=mm

    POCHY

    Sep 19, 2020 13:15

    La Solucion De "Failed To Load Window Layout" Esta En Youtube Fue Subido Por Un YouTube LLamado: POCHY

  5. 4dd85f177d19395262c4cc22a4d0cd2c?d=mm

    POCHY

    Sep 19, 2020 13:15

    The Solution To "Failed To Load Window Layout" This On Youtube Was Uploaded By A YouTube Called: POCHY

  6. 6f5eaab4188a7515a375d25d9dcec7f5?d=mm

    vladoshi

    Sep 17, 2020 21:49

    2019 worked fine. Had to upgrade for an asset. Used Unity hub to upgrade to 2020 and get this error every single time with everything old or new.

  7. A5dc4f2fa870820b431313a4774785b2?d=mm

    atmikes1234

    Sep 17, 2020 17:25

    The Workaround DOES NOT work! I changed all possible settings (language, region, country etc.) to english (us), restarted computer, also tried some of the suggestions from the comments, but nothing helped. This happened the first time, when i updated to 2020.1.5f1. I can open my old projects, but cannot create a new one.

  8. 8eca730b4397124d871b4290225372b9?d=mm

    kasd100

    Sep 17, 2020 13:01

    These are steps for a manual reset, this worked for me. After you perform these steps and get into the project, go to Layouts (top right) > More > Save to disk. This will save your onto your computer. If the problem arises again, copy the saved layout, into the same folder shown below and rename it CurrentLayout-default and delete the corrupted old one

    When you get to the 3 options
    1) Press [Load Default Layout]
    (Unity copies the correct default layout to CurrentLayout-default.dwlt)

    2a)Unity complains that it still cannot load the layout
    2b) Press Load Default Layout. (this fixes the file)

    3a) Copy the now correct CurrentLayout-default.dwlt somewhere (you can find the correct file, when you go to the folder you save your projects in, and enter the folder with the project name that you are trying to access, find “ CurrentLayout-default.dwlt” and copy it onto your computer somewhere.

    4) Press Quit
    (Unity corrupts the file during quitting)

    5) Copy back the newly saved CurrentLayout-default.dwlt into the same place you got it from and delete the old corrupted one

    6) Start Unity again

  9. 9c18d5dedccc9fef9f8bb5b9c3eb16bd?d=mm

    developers_unity222

    Sep 17, 2020 11:48

    I was able to fix the bug with this answer :

    https://gamedev.stackexchange.com/questions/103025/where-does-unity-save-the-editor-window-layouts

    I hope this can help.

  10. 9c18d5dedccc9fef9f8bb5b9c3eb16bd?d=mm

    developers_unity222

    Sep 17, 2020 11:04

    The solution did not work. I can't believe that changing the "Region and Language" could be a solution.

    Occurred to me in version 2020.1.6f and 2020.1.5f on MacOs Catalina version 10.15.6 (19G2021)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.