Search Issue Tracker

Active

Planned for 2019.1

Votes

17

Found in

2017.1.0b10

2019.1.0a11

Issue ID

1106466

Regression

No

Error message - Asset import did not unload metadata path. This will leak memory

Asset Importers

-

Reproduction steps:

1) Add a model to a project, or open the attached project
2) Click the model (Rio) in the project window
3) Click the arrow to expand the model to see all the separate parts
4) Right click the first element in the expanded pop out (In the instance of 'Rio', the icon that looks the same as the model)
5) Click 'Reimport'
6) Note errors in console:
`Assertion failed on expression: '!GetPersistentManager().IsStreamLoaded(metaDataPath)'`
`Asset import did not unload metadata path. This will leak memory. File a bug with repro steps please. (Assets/Rio.fbx)`

Comments (7)

  1. 99b6574f22f6e7ad0e30c06df69f1c22?d=mm

    avtar109

    Oct 13, 2019 08:30

    I've had this error today to it always seems to show this error along side a bunch others but then after i close the project and reopen it they disappear,

    Error Messages:
    Rebuilding Libary because the asset database could not be found!
    AssetImporter is referencing an asset from the previous import. This should not happen.
    AssetImporter is referencing an asset from the previous import. This should not happen.
    AssetImporter is referencing an asset from the previous import. This should not happen.
    AssetImporter is referencing an asset from the previous import. This should not happen.
    Assertion failed on expression: '!GetPersistentManager().IsStreamLoaded(metaDataPath)'
    Asset Import did not unload metadata path. This will leak memory. File a bug with repro steps please. (Assets/Prefabs/Bullet.prefab)

    Steps to Reproduce:
    1. Start a unity project in a previous version of unity.
    2. Once the project is saved load it up with a newer version of unity (probably best to attempt this with the newest version)
    3. Observe error

    I believe this error is being cause due to the library failing to rebuild, but when you open it the second time it doesn't need to make the library again which is why I get no error.

    Im not positive on any of this, its just a theory

  2. 8e16fd457fa8061b0e989c329dd30602?d=mm

    suinakigai

    Sep 06, 2019 13:48

    Get this error when trying to use "On Demand Remap" on imported FBX model. Pop's up after clicking "Search and Remap".

  3. 4ac01c722a5c442aa98b739f64d3d3a0?d=mm

    AA-Matt

    Aug 26, 2019 06:08

    Was working in 2019.1.14 and got this issue with a prefab variant. Same problem when I brought it into 2019.2.2. Came across another thread with the same error and a solution by Martinch01 who found that calling `AssetDatabase.ForceReserializeAssets(assetPaths)` repaired his asset. Tried it and it worked!

    Here is the thread: https://answers.unity.com/questions/1625900/why-am-i-getting-assetimporter-is-referencing-an-a.html

  4. E1e9a1145ad8c57f63522646efeed37a?d=mm

    Andy0903

    Aug 16, 2019 21:21

    Got this on a fresh install of 2019.2.1f1
    I created a simple model in Blender and imported it, no error at that time. As I uncheck the option "Import Materials" under "Materials" in the Import settings of my model and hit apply the error appears. If I check that setting again and apply I get no error. However, if I uncheck it again and hit apply the error is sent out once more.

  5. 5e6391e6b9c8a1909b84cf52903dbac3?d=mm

    lachlanmcewen

    Jul 19, 2019 12:59

    Just saw this error after setting double sided shadows for a prefab within a very simple project

  6. Df6e86428e1d855b00b6734aa85bdefd?d=mm

    Deeeds

    Apr 23, 2019 06:06

    Got this with the fresh install of 2019.1.0f2, when opening a project previously working fine in b10

    So there are no repro steps.

    It is an odd thing to ask of users.

    Just fix it for them.

  7. 0e9a020ba338eebfcd54845206d8ff1f?d=mm

    dchakrabarty

    Mar 31, 2019 05:58

    Got this error while reimporting a Generic rig after exposing some transforms.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.