Search Issue Tracker

Fixed in Unity 5.6.0

Votes

0

Found in

5.5.0f2

Issue ID

855735

Regression

Yes

Error in Console: Assertion failed on expression: '(sharedData.instructionCount == 0) || sharedData.combinedBounds.IsValid()'

Editor - Other

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Workaround is possible

Steps to reproduce:
1. Open User's attached project
2. Open scene "Main"
3. Make sure Build target is set to iOS
4. Press Play

Result: error in the Console: Assertion failed on expression: '(sharedData.instructionCount == 0) || sharedData.combinedBounds.IsValid()'

Reproduced with: 5.6.0a4, 5.5.0f2
Not reproduced with: 5.4.1f1

Comments (3)

  1. 2e8d6d3b1f7657565087efa2549d1cea?d=mm

    JonasJentsch

    Mar 21, 2017 14:35

    Had the same error because there was a canvas scaler component on a nested canvas.
    Happened because i dragged one root canvas into another existing canvas and forgot to delete the canvas and canvas scaler component on the nested one.
    Removing the canvas scaler component fixed it.

  2. E4cf240ce751f1ae990b5f256cb6b08d?d=mm

    RV1

    Jan 31, 2017 09:30

    I got this error 5.4.4p2 and it appears to be UI related. I had removed a canvas component from a game object. Then when the game object gets activated at run time, it spits out this error message. Adding the canvas component back to the game object gets rid of the error.

  3. Bf723965f3f305118079e9aef166f67e?d=mm

    breban1

    Jan 21, 2017 02:43

    I receive this error in the Player within Unity, I'm not sure what causes it, and no other info is given.

    Is this a harmless error?

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.