Search Issue Tracker

Fixed in 4.5.3

Votes

167

Found in

4.3.0f4

Issue ID

568656

Regression

Yes

Double clicking a C# script will open MonoDevelop instead of Visual Studio

CodeEditors

-

Repro steps:
1. Set Visual Studio as your external code editor in Preferences and double click on a C# script.
2. A popup box saying "Starting Visual Studio" shows up, but then it disappears and MonoDevelop opens instead.

Update 2014-06-12 please go for this URL or a discussion of the fix for this bug in 4.5.1p1 and beyond: http://forum.unity3d.com/threads/double-clicking-a-c-script-should-open-visual-studio.251358/

Update 2014-08-01 A few remaining fixes for these Visual Studio launching problems have landed and will be available in 4.5.3p1. These fixes include:

* Additional retries when a new Visual Studio session is busy while Unity attempts to open a solution file or script file.
* New logging of information about the Visual Studio detection and launching process to the editor log.

Comments (64)

  1. 0dba04b5f2f7ea65ab40c52e8f344458?d=mm

    unity_ReK9RbvLXAmYMw

    Aug 07, 2018 22:52

    im having the opposite problem, the visual studio keeps on opening up rather than mono develop, i think the problem is i didn't install the right version and i cant find any other version so if anyone can post a link to the download sight that would be great.

  2. 48de4cf02949f650d6515adb38a96f5c?d=mm

    Sk_banna007

    Jan 11, 2018 07:24

    Hey guys my c# code is effecting anything even if only writes debug. Log statement it still not giving any output at console window or not showing any error. Note that i am using unity 5.2.4f and monodevlop as script writing. Pls help me to solve this problem. Pls guys.

  3. Ff7ed3bf0e82feb43cf0166848ef92c6?d=mm

    fyodors

    Jun 18, 2017 18:15

    I'm currently experiencing this issue with 5.6.1f1 and VS 2017 community. Even if the VS is running, double clicking any script launches the mono develop and shows the error: "Could not load project 'project_name.csproj' with unknown item type '{guid}'".

  4. 4f23f5b20606e16bdd8cb2a4e22b2d7c?d=mm

    MarcusTheMainMan

    Feb 22, 2017 21:56

    Using Unity 5.51 and it still does this.

  5. C229ab4a65c236bda29bbb4c9f49b765?d=mm

    Cynikal

    Jun 16, 2016 13:33

    Manually renaming the monodevelop .exe to something else, will load Visual Studio.

  6. 8b39c74f696242f15f285fe79c6e6e71?d=mm

    harko12

    Mar 14, 2016 19:29

    YASIN.GHANNAM Definitely has it right. That was exactly my problem, I had changed visual studio to always run as administrator and unity was not. When I ran Unity as administrator, Visual Studio opened up correctly.

  7. F7e171b118d6c6cec5d33c2cf9f7991c?d=mm

    StarFluke

    Dec 19, 2015 23:39

    From http://forum.unity3d.com/threads/double-clicking-a-c-script-should-open-visual-studio.251358/#post-2431199

    Have Visual Studio 2015 sp1. After upgrading from Unity 5.2.3f1 to 5.3.0f4 I began seeing this problem: "....started saying it was opening VS and opened Mono Develop instead...."
    I upgraded to 5.3.1f1 and I am still seeing the same problem with an extra symptom:
    Now Visual Studio must Migrate the project to the current Visual Studio version. While the version upgrade is in process, Mono Develop opens.
    Other observations I see:
    The VsHub.exe tree of processes gets started. (Looks normal)
    devenv.exe gets started and just silently idles.
    The new devenv (2015sp1) includes a child process named PerfWatson2.exe when started manually; the Unity kick off never includes this child process.

    A workaround exists:
    Manually open Visual Studio and open the Unity project. Now double clicking a file will open it in Visual Studio but the whole project has to be migrated each time... it appears Unity is not accepting the Visual Studio Migration changes.

  8. Fa9be13c944c58747ca6ed2a0e9cabbf?d=mm

    Yasin.Ghannam

    Dec 13, 2015 13:14

    This might help:
    Run Unity as an administrator(right click, then choose Run As Administrator).

    I had set Visual Studio to run as administrator by default, while I always ran Unity without any administrator privilege. I guessed this might be the issue, so I ran Unity as administrator, and it worked.

  9. 91aed237e271ba342869a308ce114e7d?d=mm

    Thenegotiator

    Dec 08, 2015 21:55

    Same things happens in Unity 5.2.3f1, and I have adjusted the preferences to always start C# files with VS...

  10. 163c988a4759cd8e5770c1137c039191?d=mm

    gouthammannuru

    Sep 20, 2015 09:12

    hi every one
    i had the same problem and i broke my head but found the simplest solution

    please follow

    1. Open Unity

    2. Go to Edit (Second Tab)

    3. Click on Preferences (A new Tab will open )

    4. Click on External Tools (Second Option Available)

    5. Choose from the list of options Available

    AND YOU ARE DONE (Make sure your option of the editor is Installed first LOL)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.