Search Issue Tracker

Fixed in 4.5.3

Votes

167

Found in

4.3.0f4

Issue ID

568656

Regression

Yes

Double clicking a C# script will open MonoDevelop instead of Visual Studio

CodeEditors

-

Repro steps:
1. Set Visual Studio as your external code editor in Preferences and double click on a C# script.
2. A popup box saying "Starting Visual Studio" shows up, but then it disappears and MonoDevelop opens instead.

Update 2014-06-12 please go for this URL or a discussion of the fix for this bug in 4.5.1p1 and beyond: http://forum.unity3d.com/threads/double-clicking-a-c-script-should-open-visual-studio.251358/

Update 2014-08-01 A few remaining fixes for these Visual Studio launching problems have landed and will be available in 4.5.3p1. These fixes include:

* Additional retries when a new Visual Studio session is busy while Unity attempts to open a solution file or script file.
* New logging of information about the Visual Studio detection and launching process to the editor log.

Comments (64)

  1. A20fc29d791bbeaa657995701bd3a9ed?d=mm

    CubicGames

    Jan 11, 2014 23:20

    Same here with VS 2010 Ultimate, Win 7 x64 and Unity 4.3.2f1

  2. 6bf36a42e12f34ba5091b4feb8984ea5?d=mm

    TobiasW

    Jan 08, 2014 01:03

    Same problem for me: Win7, VS 2013.

    It worked fine for me as long as I only had VS 2013 installed. Broke when I also installed VS 2010 afterwards.

  3. C43d887bb215ea16084fa2eb4ff5e774?d=mm

    Archimagus

    Jan 05, 2014 19:41

    I have a clean install of windows. I installed Visual Studio 2013 first, then Unity3D.

    Any project I have, I create a C# script, then double click to open it. I get the "Opening in visual studio" dialog then it goes away and Monodevelop starts. If I have visual studio open to the project first then the script opens in Visual Studio.

    I tried renaming Monodevelop.exe to prevent it from opening and this seems to give a clue to what is happening. After the rename, now double clicking a script causes it to open in Visual Studio, but it just opens the script, not the solution file.

    I am fully willing to help debug this further if you have anything you would like me to try.

    Thanks

  4. Eea0ff4b114d36fe8ae7a8de8efc8ad3?d=mm

    ReVo_

    Jan 04, 2014 18:27

    Windows 7 - Visual Studio 2013 and Visual Studio 2010 installed.
    Opens VS 2010 and not VS 2013 (VS2013 is selected in the settngs)

  5. A5d6ca1107e75169a207f106b6f8d95c?d=mm

    Omega_

    Dec 30, 2013 22:17

    This should be addressed.

  6. 121a25c379b67e7ff603a3ceb16733a2?d=mm

    mikaelwallin

    Dec 10, 2013 15:01

    For me it opens VS2010 instead of VS2013 despite that I chose VS2013

  7. 941e0894c545bb07831ec250520fbb67?d=mm

    Azzara.

    Dec 08, 2013 18:35

    4.3.1
    Unity incorrectly creates a solution file with "Format Version 11.00" when syncing with VS 2008. It has to be version 10.00.
    It also incorrectly creates project files with ToolsVersion="4.0". The correct version for VS 2008 is 3.5
    I've noticed that opening a C# script creates a new ghost process called devenv.exe before runing MonoDevelop.

  8. 294f50ca5a02046766ae6ca75e596617?d=mm

    gridside

    Dec 02, 2013 11:18

    Same here.
    Win8 - VS 2012

  9. 82881e5c9d038fdbbccfae08fd8101eb?d=mm

    cadaver

    Nov 28, 2013 13:36

    Happens with Win7 + Unity 4.3.0f4 + VS 2008 Pro. VS 2010 Express also installed, but cannot be used as Unity says it cannot control it.

  10. 808d1cf4d920c13f087f31d3c69c4874?d=mm

    tiiser

    Nov 28, 2013 13:04

    Win7, Unity 4.3.0, VS 2008

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.