Search Issue Tracker

Not Reproducible

Votes

15

Found in

2020.3

2021.2

2021.2.4f1

2022.1

Issue ID

1389282

Regression

No

"Curl error 60: Cert verify failed" error when using UnityWebRequest.Get on HoloLens 2

Networking

-

How to reproduce:
1. Open the attached project "SSLerror.zip"
2. Open File>Build Settings...
3. Switch Platform to Universal Windows Platform
4. Build And Run on HoloLens 2

Expected results: No errors in the Development Console
Actual results: "Curl error 60: Cert verify failed: UNITYTLS_X509VERIFY_FLAG_USER_ERROR1" error in the Development Console

Reproducible with: 1.3.0, 1.3.1 (2020.3.25f1, 2021.2.7f1, 2022.1.0b2)
Could not test with: 2019.4.34f1 (OpenXR unavailable)

Comments (8)

  1. dbtactic

    Jun 15, 2022 17:54

    I am also seeing this error in 2021.3.2f1.110, in Windows 10 in the editor.

  2. dbtactic

    Jun 15, 2022 16:49

    I am also seeing this error in 2021.3.2f1.110, in Windows 10 in the editor.

  3. ill_tonkso

    Mar 02, 2022 12:58

    Reproduced on Android. 2021.2.4f1 and 2021.2.13f1. Tried using UnityWebRequest and legacy WWW method.

  4. WoodsFiend

    Feb 26, 2022 01:21

    After a long investigation I found that a UnityWebRequest to hosts using ISRG Root X1 root certificate seem to always use the cross-signed certificate instead of the self signed certificate. I think this might be the cause of the issue and is not specific to hololens. Happens to me in the editor and windows build.

    I have a simple project that shows the issue: https://github.com/WoodsFiend/ImageDownloadTest

    To test:
    - Run in editor and it will fail to download image
    - Using Charles to see request info, add assets.polkamon.com to the Charles proxy settings
    - Test download image again from editor (now succeeds because of proxy) and look at the ISRG Root X1 for the request in Charles. Make note of the serial and expiry date (expiry year 2024 = cross signed cert from expired DST Root CA X3)
    - Test the same image URL from browser, use console -> security to see cert chain. Different serial and expiry date for ISRG Root X1 cert (expiry year 2035 = correct self signed cert)

  5. unity_468EA0230C8F329D08FB

    Feb 17, 2022 20:53

    I was having the same error using Unity 2020.3.24f1 for a UWP ARM64 Build for the HoloLens 2, against a CCD bucket.
    My initial solution was to move to a AWS S3 (publicly open) and replace the request's uri HTTPS to HTTP.

    I updated to 2020.3.28f1 and my CCD requests now work on the device.

    Unity Answer
    https://answers.unity.com/questions/1885554/unitywebrequests-constantly-fail-with-ssl-ca-certi.html

    Issue 1387295
    https://issuetracker.unity3d.com/issues/tlsexception-handshake-failed-error-when-uwp-build-configuration-is-set-to-release

  6. unity_5BE91AF363F8CDCF129A

    Feb 05, 2022 06:05

    I met the same problem.
    I get this error when I send an Http request using HttpClient.

    It occurred on 2020.3.25f and 202.3.26f.
    It did not occur in 2020.3.19f.so I use 2020.3.19f.

  7. WoodsFiend

    Jan 19, 2022 01:04

    Same problem in the same Unity version. Happens in both editor and builds on Windows 10

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.