Search Issue Tracker

Fixed in 2020.2

Fixed in 2019.4, 2020.1

Votes

3

Found in

2019.3.15f1

2020.1.0b2

2020.2.0a1

Issue ID

1230177

Regression

Yes

Crash on GetRenderPipelineScript when opening a specific project

Graphics - General

-

Reproduction steps:
1. Open the attached project ("1230177.zip")
2. If the project didn't crash, close the project and reopen it

Reproducible with: 2020.1.0b2, 2020.1.0b3, 2020.2.0a1, 2020.2.0a4
Not reproducible with: 2019.3.7f1,2020.1.0a1, 2020.1.0b1

First lines of the stacktraces:
0x00007FF7216A7729 (Unity) GetRenderPipelineScript
0x00007FF7216B2B27 (Unity) ScriptableRenderContext::ShouldUseRenderPipeline
0x00007FF7240BB89C (Unity) ShouldGenerateTiersForSnippet
0x00007FF721980B76 (Unity) ShaderLab::Program::CompileShaderSubProgram
0x00007FF721982B97 (Unity) ShaderLab::Program::GetMatchingSubProgram

0x00007FF721E7FDEB (Unity) scripting_thread_is_attached
0x00007FF721E79DAE (Unity) ScriptingInvocation::SetDefaults
0x00007FF721E72C9B (Unity) ScriptingInvocation::ScriptingInvocation
0x00007FF721219E27 (Unity) GraphicsSettings::CleanupRenderPipeline
0x00007FF7216B2B4B (Unity) ScriptableRenderContext::ShouldUseRenderPipeline

  1. Response avatar

    Resolution Note (fix version 2020.2):

    Fixed in 2020.2.0a7

  2. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in 2020.1.0b5

  3. Response avatar

    Resolution Note (fix version 2019.4):

    Fixed in 2019.4.3f1

Comments (13)

  1. 03053c9f839d1b04f88b79abbb730816?d=mm

    zackblack

    Jul 15, 2020 14:39

    This appears to have been fixed in 2019.4.3f1, even tho it's still listed as a known issue. Sheesh.

  2. Ddd9b7fb724f92a176b14e38b0f2a701?d=mm

    ErThu

    Jun 19, 2020 21:08

    Also not fixed in 2019.4.1f1

    My current workaround: Delete Library/SourceAssetDB every time you want to start Unity.

  3. 6dfd5dca946ed481df75c9d37d59a28e?d=mm

    Leotte_CreativeDrive

    Jun 19, 2020 12:34

    Still not fixed in 2019.4.0f1, only workaround that exists is not using the Preloaded Shaders as reported above by BRADLEYFSHEPHERD.

  4. C588d6e51490389e9fbe3537c2146a21?d=mm

    juanfornos

    Jun 12, 2020 19:09

    Updated to 2019.4 LTS and experiencing this. Can't open the project.

  5. Ecdb0d77fb3649c46b8c0d65755b8de1?d=mm

    SpaceBoatStudio

    Jun 09, 2020 18:47

    same here on 2019.4 LTS

  6. 7da04df4931464797c5724ae66024847?d=mm

    gjf

    Jun 01, 2020 11:02

    As a follow-up, the removal of the preloaded shaders allows the affected project to be reloaded (as noted by others).

  7. 559910b1af4ab0bbb08e6f409f5ded3f?d=mm

    Sasasoft

    May 31, 2020 10:58

    I just update to 2019.3.15f1 from 2019.3.7f1, then the same crash on project load problem occured the same way as described above. I didn't had this problem with 2019.3.7f1.

    As suggested by gjf and deram_scholzara, deleting the Library folder solved the problem for one launch. Closing then loading the project again crashes Unity.

    As suggested by bradleyfshepherd, removing the preloaded shaders solves the problem. The project can be loaded multiple times without deleting the Library folder.
    I only had one Shader Variant Collection in the preloaded shaders option. It was my mistake that it was left there, because it contained built-in shaders while I'm in the middle of migrating to URP.

  8. 7da04df4931464797c5724ae66024847?d=mm

    gjf

    May 30, 2020 14:49

    This is still an issue for 2019.3.15f1 for one of our projects.

    Recent Unity builds in the 2019.3 release stream have not exhibited this issue - it's new to 2019.3.15f1, or at least only manifesting itself now.

    Deleting the Library folder allows the scene to load but various settings need to be applied every time which is time-consuming and renders Unity practically unusable right now.

  9. Bf086228f82513dfc373baba6a2de8ec?d=mm

    thomas-weltenbauer

    May 28, 2020 07:51

    I also have this issue in 2020.1.0b10 if I try to open our project

  10. 1c6819b132faf28ddac1eb20952765e0?d=mm

    bradleyfshepherd

    Apr 27, 2020 20:12

    I was able to workaround this bug by removing the shader variants from the Preloaded Shaders (set Size to 0) in the Project Settings > Graphics.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.