Search Issue Tracker

Fixed in 2018.1

Planned for 2017.4

Votes

0

Found in

2017.4.29f1

Issue ID

1170714

Regression

No

[Build Pipeline, Meshes] Mesh Optimization is not using enabled Material Keywords

Graphics - General

-

To reproduce:
1. Open attached project "ShaderTest copy.zip", scene Start
2. Build and Run the project
3. Observe the model in built application

Expected: mesh data is present after building no matter what scene is open
Actual: normals are not included in mesh data

Reproduced in: 2017.4.0f1, 2017.4.30f1
Not reproduced in: 2018.4.5f1, 2019.1.12f1, 2019.2.0b10, 2019.3.0a10

Comments (2)

  1. 9d11138cb1b0aa54ce77fd74e9d3c873?d=mm

    abduljabbar0001212

    Aug 09, 2019 11:58

    Yes @sarah this code is working I have tried. This code is shared by https://essaywritingservice.ae/ first. they are really helpful

    Using UnityEngine;
    Using UnityEditor;
    Public class example: MonoBehavior
    {
    Void Start()
    {
    Meshmesh = gameObject.GetComponent<MeshFilter>().mesh;
    MeshUtility.Optimiza(mesh);
    }
    }

  2. Aba7067ebb39b84cf7d478e9355c02d6?d=mm

    sarah009

    Jul 23, 2019 06:36

    I have tried one code with the help of https://www.gulfwriter.com/, which is as
    Using UnityEngine;
    Using UnityEditor;
    Public class example: MonoBehavior
    {
    Void Start()
    {
    Meshmesh = gameObject.GetComponent<MeshFilter>().mesh;
    MeshUtility.Optimiza(mesh);
    }
    }

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.