Search Issue Tracker

Fixed in 2021.1.X

Fixed in 2018.4.X, 2019.4.X, 2020.1.X, 2020.2.X



Found in






Issue ID




[Android] Keyboard doesn't show up when trying to input text in an Input Field with Hide Mobile Input checked on Android 11



Repro steps:
1. Create a new project and create an Input Field (reproduced with regular and TMPro Input Fields)
2. Build and Run on an Android device with Android 11
3. Press on the Input field

Actual: The keyboard doesn't show up

Reproducible with: 2018.4.24f1, 2019.4.2f1, 2020.1.0b14, 2020.2.0a16

Tested and reproduced on these devices:
VLNQA00001, Google Pixel 2 (Pixel 2), Android 11, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540

Didn't reproduce on:
VLNQA00013, Samsung Galaxy S6 edge+ (SM-G928F), Android 7.0, CPU: Exynos 7 Octa 7420, GPU: Mali-T760
VLNQA00078, Motorola Nexus 6 (Nexus 6), Android 7.1.1, CPU: Snapdragon 805 APQ8084AB, GPU: Adreno (TM) 420
VLNQA00225, Qualcomm (SDM845 for arm64), Android 8.1.0, CPU: Snapdragon 845 SDM845, GPU: Adreno (TM) 630
VLNQA00128, Samsung Galaxy Note8 (SM-N950F), Android 9, CPU: Exynos 9 Octa 8895, GPU: Mali-G71
VLNQA00317, Vivo V1924A (V1924A), Android 9, CPU: Snapdragon 855 SM8150, GPU: Adreno (TM) 640
VLNQA00294, Oppo Reno Z 中国版 (PCDM10), Android 9, CPU: Mediatek MT6779 Helio P90, GPU: PowerVR Rogue GM9446
Oneplus OnePlus 6 (ONEPLUS A6003), Android 10, CPU: Snapdragon 845 SDM845, GPU: Adreno (TM) 630

Comments (31)

  1. prenner1

    Oct 27, 2020 12:08

    In 2019.4.12, this is unfortunately still not working using TMP.

  2. DevDeveloperDev

    Oct 26, 2020 18:06

    This still isn't fixed. can we get an update on this. Its a pretty big deal for our app.

  3. l_gran

    Oct 26, 2020 07:16

    Still happens in Unity 2018.4. And we're using TextMeshPro components

  4. WillMaestro

    Oct 21, 2020 17:44

    Update: This is fixed for regular Unity input components, we were using TextMeshPro input components for which this is not fixed

  5. altaf_unity940

    Oct 21, 2020 04:09

    Looks like it will be fixed in 2019.4.13f1

  6. WillMaestro

    Oct 20, 2020 15:30

    Tried in 2019.4.12f1 and 2020.1.9f1 and neither worked for us on Android 11 even though it is marked as fixed in both versions. This issue interferes with the launch of our app as our users are unable to sign in without keyboard input, please fix asap

  7. andersemil

    Oct 19, 2020 09:47

    Still not working in 2018.4.28. We need this fixed NOW

  8. jj1991

    Oct 15, 2020 11:34

    Still not working in 2019.4.12f1

  9. Nickjd331

    Oct 14, 2020 13:58

    Also having this issue in 2019.4. Users cannot log into my app at all.

    Will have to try doing a temporary hot fix like ANDERSEMIL, and then a subsequent one again after it's resolved.

  10. Martin_Gonzalez

    Oct 13, 2020 13:24

    2018.4.28 still happen

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.