Search Issue Tracker

By Design



Found in





Issue ID




[Android] AWS SDK stopped working in Android Builds with Unity 2019.1.0a1 and up



To reproduce:
1. Open the user's attached project
2. Build and Run on Android device

Expected result: Function outputs a result
Actual result: Function is never called, an error occurs

Error Unity: Unable to find /usr/lib/libobjc.dylib

Reproduced with: 2019.1.0a1, 2019.1.0f2, 2019.2.0a14, 2019.3.0a1
Not reproduced with: 2018.3.14f1
Does not reproduce with iOS, Windows, Mac standalone. Only with Android

Tested and reproduced with these devices:
VLNQA00124 Google Pixel 2 XL 9 Snapdragon 835 MSM8998 Adreno (TM) 540 OpenGL ES 3.2
VLNQA00218 Samsung Galaxy Note9 8.1.0 Snapdragon 845 SDM845 Adreno (TM) 630 OpenGL ES 3.2
VLNQA00257 Sony Xperia XZ Premium 8.0.0 Snapdragon 835 MSM8998 Adreno (TM) 540 OpenGL ES 3.2
VLNQA00266 Xiaomi Mi A2 8.1.0 Snapdragon 660 Adreno (TM) 512 OpenGL ES 3.2

  1. Resolution Note (2019.3.X):

    This is an issue in GetJavaObjectStatically() method in the AWS SDK.

Comments (14)

  1. krissmith

    Dec 10, 2019 15:34

    Hello guys. I'm getting the same errors but I'm getting those when trying to call a Lambda function with Amazon.Lambda.AmazonLambdaClient.InvokeAsync.

    Just to make clear: this issue is happening in Android builds with Unity 2019.1.0f2. The AWS plugin works fine in the Unity Editor.

    I work as trainer in below company where i have to shown how to resolve this issue..

  2. hsr38

    Sep 24, 2019 14:05

    Hello, this issue is not solved at all. I'm not sure why it is marked as so in the first place. I have encountered it while working with dynamodb for android, using unity aws sdk. I can confirm unity version 2019.2.4f1 still has the issue.

  3. alexblabla

    Jun 28, 2019 08:03

    Solved by exporting my project as a unity package and importing it into a new project made in Unity 2018.3.14f1...after that you only have to write your tags again and delete the following files: androidx.browser.browser-1.0.0
    from \YoureProjectLocation\Assets\Plugins\Android

  4. mathandlove

    Jun 08, 2019 20:50

    As this is marked as resolved, can we use Amazon Web Services with 2019 now?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.