Search Issue Tracker

Fixed in 1.1.0-pre.5



Found in [Package]


Issue ID




[XR][OpenXR] "Could not create a device for <...>" error is thrown when entering Play mode after installing OpenXR package

Package: Input System


Reproduction steps:
1. Open the user's attached "" project
2. Load WorldInteractionDemo scene
3. Open the PackageManager and reinstall the OpenXR package
4. Open the Project Settings > XR Plug-in Management and enable OpenXR
5. Make sure Oculus Touch Controller Profile is added in XR Plug-in Management > OpenXR settings
6. Make sure HMD and XR Controller are active
7. Enter Play mode and observe the Console window

Expected result: there are no errors
Actual result: "Could not create a device for 'Oculus Oculus Touch Controller OpenXR (XRInputV1)'" error is thrown

Reproducible with: OpenXR 1.2.0, 1.2.2 (2020.3.12f1, 2021.1.121, 2021.2.0b1)
Not reproducible with: OpenXR 1.1.1 (2020.3.12f1)
Could not test with 2018.4, 2019.4 (OpenXR package is not available)

- the issue is no longer reproducible after restarting the Editor
- updating InputSystem from 1.0.2 to 1.1.0-pre.5 resolves the problem

Tested with:
- Oculus Rift and Oculus Touch Controller

  1. Resolution Note (fix version 1.1.0-pre.5):

    Updating to 1.1-pre.5 of com.unity.inputsystem should fix the issue. We're working on getting 1.1 final/verified of the package out which on release should solve the issue out of the box.

Comments (6)

  1. OgnjenSelver

    Oct 13, 2021 09:45

    For me fix was upgrading input system to 1.1.1 from 1.0.2

  2. hibi0422

    Aug 15, 2021 13:58

    I don't know if this is correct, but here is how I solved it.

    1Remove the Oculus XR Plugin
    2Remove the XR Interaction Toolkit-pre.5 and install it again.
    3Import the "Controller", "Meshing Subsystem Feature", and "Intercept Feature" from the OpenXR Plugin Sample.

    After doing this, it now works without any problems.

    This has been translated at DeepL.

  3. ANS_TT_VR

    Aug 06, 2021 18:02

    I rolled back to version 1.0.2 (The current certified one) and Exported the whole scene into another brand new Unity environment. It worked without issues.

  4. ANS_TT_VR

    Aug 06, 2021 17:33

    Installing 1.1-pre.5 fixed the error for me, but now both hand controllers are gone X_X

  5. rahebn

    Aug 04, 2021 18:07

    Removing the Localization package solved for me!

  6. rahebn

    Aug 04, 2021 18:02

    I started to get these errors after installing the Localization package.
    Upgrading the inputsystem did not solve it for me

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.