Search Issue Tracker

Fixed in Unity 2017.3

Votes

2

Found in

2017.1.0f3

Issue ID

940942

Regression

Yes

WWW returned URL missing slashes (WebGL build)

WebGL

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Workaround is possible

1. Load up attached project (OC link in comments, file name "940942-UploadTest.zip")
2. Build for WebGL on at least two versions (one it works with and one it does not work with)
3. Host somewhere
4. Load up the build on an internet browser
5. Press Upload Image (click twice)
6. Select any image from the hard drive
7. The image will either get loaded or not depending on which version the project was built with

OR

1. Download attached builds (2017.1b3 for one that doesn't work (171b3-build.zip), and 5.6.3p1 for one that works (563p1-build.zip))
2. Continue at #3

Expected result: images are loaded onto the cube in any build
Actual result: no image is loaded because the returned path drops slashes

Reproducible with: 2017.1.0b3, 2017.1.0b4, 2017.1.0b5, 2017.1.0f3
Not reproducible with: 5.6.2f1, 5.6.3p1, 2017.1.0a1
Regression introduced in: 2017.1.0b3

Note: the project did not build on 2017.1.0b1 and 2017.1.0b2 for some reason so there's a slight chance the regression might have been introduced there

Comments (1)

  1. 42a62017cea6dc1e781403d7144659cd?d=mm

    sumpfkraut

    Oct 30, 2017 08:11

    Also in 2017.1.2p2

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.