Search Issue Tracker

Fixed in 4.5.6

Votes

24

Found in

4.3.2f1

Issue ID

615033

Regression

No

Unity web player game using Google Chrome will not allow input

Webplayer

-

Steps to reproduce:
1. Open the build (build/build.html) with Chrome or build the project to webplayer platform
2. Press 'Run this time' when Chrome asks permission for using Unity web player
3. Click on the game with left mouse button
4. Try to move with WASD - no movement input gets registered. Minimize-maximize Chrome. It now gets input.
5. Repeat step 2 and don't click on the game window. Game receives input.

Comments (15)

  1. Ee301e8c03f72615a25ab3ccbddf45d4?d=mm

    Xesas

    Mar 19, 2015 17:13

    I'm having this issue as well. Game doesn't accept input unless it is full-screen ( on Mac) .Works fine on Windows for Firefox and Chrome. Does not work On Mac on Firefox OR Chrome. I'm Using Unity 4.6.3.

  2. 34f84ffa1073a3b74ba8c8ca21b2dd1f?d=mm

    Praesidium

    Feb 23, 2015 15:34

    this is still not fixed :X still happening on chrome 40.0.2214 64bits on mac osx 10.9.5

  3. 04bdb978b287e33bf476714f9cbb54c7?d=mm

    winnie_2

    Dec 13, 2014 16:02

    Sorry all the issues are not fixed get on it unity it still won,t work right on Google chrome

  4. 02d3cb6700ba6024d0d88dd8795772af?d=mm

    gediminasp

    Oct 30, 2014 11:14

    Hi,

    This issue does not reproduce with the latest Chrome version (Chrome 38 to be exact).

    Gediminas
    QA team

  5. 07abf13f58af09ff28375e724ac11b29?d=mm

    pf-gdev

    Oct 29, 2014 19:08

    Definitely needs to be fixed asap.

  6. Ba088204b9148fb38a5b94c52d43c4af?d=mm

    birbilis

    Oct 24, 2014 12:47

    btw, can I somehow mark with a "watch" flag a thread like this to get e-mail notifications when more replies are added to the thread? (like Codeplex [say at http://clipflair.codeplex.com] has in discussions?)

  7. Ba088204b9148fb38a5b94c52d43c4af?d=mm

    birbilis

    Oct 24, 2014 12:44

    if it's on MacOS Chrome version only, it may be related to the same issue that also Silverlight is having. Silverlight 4 I think was working OK and getting input from Chrome on MacOS and then Silverlight 5 broke it. I don't think it was some new version of Chrome that had broken input there (say in RichTextBox), but the new version of SL. So maybe they could find those two versions and see with some debugger how they behave differently on MacOS Chrome to see if they can use that to fix the issue. Then maybe Unity team could pass on that info to Microsoft to finally fix Silverlight on MacOS Chrome (have this problem with ClipFlair Studio for a long time now [http://ClipFlair.net] and suggest to people to use Firefox instead on MacOS-X)

  8. Ff1fd9ce15d6a5c84d9aa695236471d2?d=mm

    Illuminaty

    Oct 24, 2014 12:25

    Ok. even though this is probably a unity problem of inconsistency between platforms, I found a solution that worked for me.

    I'm using NGUI, and I had a very wild guess of unchecking clip raycasts, and that solved the problem!
    I googled and found that perhaps Panels don't get instantiated correctly on the Z axis.
    In any case, I'm curious to see if this helps others, too.

  9. Ff1fd9ce15d6a5c84d9aa695236471d2?d=mm

    Illuminaty

    Oct 22, 2014 21:24

    Anyone? It's gonna be really difficult to try and roll back everything to a working version, whichever that would be.
    How come they haven't dealt with this issue?

  10. 5e9b567f8e474dcc5fb641658ba09085?d=mm

    scnoobi

    Oct 15, 2014 17:25

    get on it unity!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.