Search Issue Tracker

Fixed in 2019.3.X



Found in


Issue ID




[Unity Hub][Android][NDK] Integrated NDK version is not compatible with available Unity Hub or Android developer NDK versions



How to reproduce:
1. Download 2019.3.0a4 trough Unity Hub with Android + NDK/SDK tools, notice that r16b is downloaded
2. Try to do Android IL2CPP build and notice that Editor complains about NDK tools not found
3. Download latest NDK r19 version from Android developer page -
4. When setting to the newest NDK, you will get the error message "NDK 19.2.5345600 detected. Unity requires NDK r19 (64-bit) (19.0.5232133)."

Reproducible with - 2019.3.0a4
Not reproducible with - 2019.3.0a3

Workaround until the correct version will be downloaded via Hub is to download r19 version from the directly. Just follow the steps to download the latest ndk r19 version (currently it's r19c) and once you'll have the download link, just delete the letter after the version number, so the link would have only ndk-r19.

Fixed in Unity Hub 2.0.4 version

Comments (21)

  1. 16e94268f3e8a3c343baf65e2f22f477?d=mm


    Aug 26, 2019 14:00

    changing the file -Pkg.Revision to 19.0.5232133 worked.For the people who downloaded the NDK manually "" stays inside the downloaded ndk folder.It was my bad searching the installed unity folder for "".Thank you devs

  2. 16e94268f3e8a3c343baf65e2f22f477?d=mm


    Aug 26, 2019 13:04

    issue happens in 2019.3.0.a12. what is the path for in Mac.Thanks in advance

  3. 9aae9c54a74c3aeb6dc8405a9b1c7018?d=mm


    Jul 03, 2019 05:14

    change Pkg.Revision to 19.0.5232133.... it's work Bro

  4. F3e197ff23a3d4d1b592a30ce7904844?d=mm


    Jul 03, 2019 01:19


    I tried suggestions and I have a new message:

    "You are missing the recommended NDK. "

    Did you get the same result?

    Thank you,
    Sis Moon

  5. 6e2f39089111c45f354afb74f1873bae?d=mm


    Jun 30, 2019 11:45

    Open ...Unity\Editor\2019.3.0a7\Editor\Data\PlaybackEngines\AndroidPlayer\NDK\ and change Pkg.Revision to 19.0.5232133

  6. D35f32bf38b0683b9f2c98fcdda0cb66?d=mm


    Jun 29, 2019 23:25

    Present in 2019.3.0a7

  7. 298496730e0cc6e7c25b70eb4917ea38?d=mm


    Jun 26, 2019 09:47

    my version is 2019.3.0a6

  8. 298496730e0cc6e7c25b70eb4917ea38?d=mm


    Jun 26, 2019 09:45

    Does not work on me it says NDK 19.2.5345600 detected UNITY requires NDK r19 (64-bit) (19.0.5232133). I removed the letter as you said but does not work

  9. 13c6b5b10f847a73aee1b0e68de21e74?d=mm


    Jun 11, 2019 08:51

    The problem exists in version 2019.3.0a5 also.

  10. 960f0f231632cb2bcd6873fc95934eb1?d=mm


    Jun 07, 2019 00:41

    uh i meant NDK r19 (64-bit) (19.0.5232133)

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.