Search Issue Tracker

Active

Planned for 2.1.X

Votes

23

Found in [Package]

2.1.2

Issue ID

HUBX-472

Regression

No

Unity Editor install via Hub fails silently when installing it on Mac account without admin privileges

Package: Hub

-

Repro steps:
1. Log in to a Mac account with no admin privileges
2. Open Unity Hub
3. Start installing any version of Unity Editor

Expected results: installation fails, the user is requested to elevate privileges of the installation folder
Actual results: after seemingly being downloaded for a while, installation disappears from the Installs tab with no error messages

Reproduced with: Unity Hub 2.1.2, Unity hub 2.1.3

Note: issue also reproduces if the Editor is being installed on an admin account if Unity Hub was originally installed by another admin account

Assigned to Customer QA Grabbag by Leonhard Pickny 24/10/2019 10:24
Forum thread:
https://forum.unity.com/threads/unity-hub-cannot-install-unity-when-it-needs-to-elevate-privileges-on-mac.514088/

Comments (9)

  1. 7a54d4280c59180d7517be74cc6b8127?d=mm

    eshanraop

    Jul 13, 2021 16:41

    Still not fixed

  2. E1032ee861e0a9ca66f3cfcaa788621c?d=mm

    chillyroom

    Apr 29, 2021 10:26

    Unbelievable. Multiple issues on this and still not fixed.

  3. Db4c4acad39d8d8d081af89323224c48?d=mm

    DHARMAKAYA

    Apr 22, 2021 19:46

    Come on...this is RIDICULOUS. Any workaround to solve that?

  4. 558eba41efc8f010c2744e8fb782633f?d=mm

    therealluketomes

    Oct 16, 2020 20:30

    This is a really annoying way of doing things, huge 10 GB download, then fail silently and delete the files. At least get an error message in the UI.

  5. Ee1efe7dc3eb04d507c53a062244219d?d=mm

    firstuser

    Sep 18, 2020 23:37

  6. 63ca35ccc0a541c1dbac59ed4f103aca?d=mm

    Meatgrind

    Sep 10, 2020 10:03

    Unity Hub 2.4.0 claims it validates install location in its release notes, but the same problem still occurs: lengthy download goes first, then it silently fails and leaves a notion about "missing location" in the Unity Hub logs, because the Applications/Unity/ folder has been originally created by some other user than the current admin one I'm running.

    As a workaround allowing Read&Write for my current user/admin group as well as "everyone" recursively for everything starting at Applications/Unity/ does help to fix the issue, but it's a bit tedious and a bad practice to just instruct users to go around elevating access for every folder whenever there's problems.

  7. 8dfc817d3f2f0607a121608cef02f1a1?d=mm

    Kris602

    Jun 24, 2020 03:06

    I ran into this issue in the spring but didn't have time to troubleshoot. Just used the direct Unity installer, if I remember correctly. Pointed all 20+ of our Macs to the resulting install location manually.

    Now I have more time.
    What's the update on this? Just ran into this issue again.
    Is there a work around yet? Besides privilege management solutions cooked up by our IT department, I either need to have an admin do this or go the direct install route and still have just as much work to do.
    This puts quite a large wrench in our workflow for software deployment and configuration.

    As referenced previously, this issue dates back to at least January of 2018, probably even further.

  8. Fb42e2ae500a7c1ebf3f624b2d2259d7?d=mm

    gundeep2

    Apr 20, 2020 12:25

    This issue wastes tremendous amount of time, each time you try, you first download such big files only to realize after the download is finished that it was un-successful and everything you downloaded gets deleted silently from temp files.

    they just need to ask for elevation of permission before copying installer. and its been pending for a long time see the linked forum-

    https://forum.unity.com/threads/unity-hub-cannot-install-unity-when-it-needs-to-elevate-privileges-on-mac.514088/

  9. 98d9d75a4f035b831029a62572216685?d=mm

    Resin

    Nov 08, 2019 23:30

    Is there a good work around for this?

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.