Search Issue Tracker

Fixed in 2018.3.X

Votes

21

Found in

5.4.0b21

Issue ID

804835

Regression

No

Network configuration mismatch detected even though host's and client's networking scripts are the same

Networking

-

Steps to reproduce:
1. Open "Bomberman" project
2. Open "Lobby" scene
3. Build and run the project
4. In the Build press "LAN Host(H)"
5. In Editor press "LAN Client(C)"
-- Notice Warning in the console which says that network configuraiton mismatch detected

Expected: Client's network configuration should be the same as the Host's.
Actual: Network configuraiton mismatch detected

Note: You can get same error when you host a game in editor and connect to it with build. However, you should look for warning in the output_log.txt.

Reproduced with: 5.4.0b21, 5.3.5p3, 5.2.4f1

Comments (9)

  1. mauri_galvez

    May 05, 2017 17:26

    I have the same problem as KALEIDOSGU. Even if I make a build in a new folder, the date is from a month ago or so. Has anyone found out the reason of this?

  2. kaleidosgu

    Apr 19, 2017 01:58

    And I found a problem. If you met this problem, you would find the building exe file will be expired file. The datas files will be build on time. Even you delete the exe file. It will generated by the building in expired data file again.

  3. LucyLuna

    Apr 10, 2017 09:25

    I still got this bug in 2017 (T_T)

  4. l3fty

    Oct 21, 2016 18:41

    I've also started getting these CRC Mismatch warnings appear on the client. I'd love to know if there's a bug here, or something I'm doing wrong. Interestingly when I switched which machines were server & client around I received an actual error (InvalidOperationException) on the client(which was then running on the faster machine).

    This image shows the details of the error recieved, in case this sheds some light on the issue.
    http://www.l3fty.com/mismatch_error.jpg

  5. vicator

    Oct 08, 2016 22:13

    ... and let me comment some more. Just happened again as I was switching scenes back and forth. The 6th prefab in the network manager suddenly disappears randomly when switching back and forth. I'll try to keep an eye on it.

    Version: 5.4.0f3

  6. vicator

    Oct 08, 2016 21:48

    Got the same issue - here is my finding of how I solved this once. Note that I have not ran or opened your project.

    In one of my projects I can swear I registered my prefab as a spawnable object. But after a couple of hours or so it seems that the prefab was no longer in the network manager spawnable items list anymore. I have no idea how it was lost. Adding the prefab again and rebuilding the whole thing solved the problem.

  7. bazzer

    Sep 02, 2016 05:27

    Yeah, I have started getting this issue as well out of the blue.
    If I recreate the prefab involved from scratch it sometimes goes away.
    No idea what's causing it.

  8. Lohoris2

    Aug 16, 2016 15:29

    I suddenly started having the same problem, out of the blue.

    Yesterday the project ran just fine, today I get these random errors.
    Still trying to pinpoint what may have triggered it, but however it goes, it makes no sense: it claims the server and client mismatch, when they shouldn't.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.