Search Issue Tracker


Fixed in 2020.3.39f1, 2021.3.9f1, 2022.1.10f1, 2022.2.0a5



Found in






Issue ID




"Unable to read header from archive file: memarchive0" error thrown in the Console window when entering the Play Mode



Reproduction steps:
1. Open the attached Unity project
2. Go to the Scenes folder and open "02_Menu.unity" Scene
3. Enter the Play mode
4. Observe the errors in the Console window

Expected result: No errors are thrown in the Console window when entering the Play mode
Actual result: Multiple errors are thrown in the Console window when entering the Play mode: "Unable to read header from archive file: memarchive0", "Mounting archive file system for lighting data asset failed!"

Reproducible with: 2022.1.2f1, 2022.2.0a4
Not reproducible with: 2019.4.39f1, 2020.3.35f1, 2021.3.3f1, 2022.1.1f1, 2022.2.0a5, 2022.2.0a15

Reproducible on: macOS 12.3.1 (Apple M1 Max) Editor, Windows 10 (Intel(R) Core(TM) i9-10980XE CPU 3.00GHz) Editor

- Errors are also thrown when building the project for Mac Standalone, but the build is successful

Comments (6)

  1. PrairieDogSeeksHeart

    Dec 16, 2023 06:21

    TWENTYEDGES solution worked for me as well! Thank you!

  2. rmiha

    Sep 20, 2023 09:41

    Thanks TWENTYEDGES, solution worked for me too!

  3. brunogattai1996

    Jul 25, 2023 14:59

    Cleaning the GI Cache worked for me, thank you for sharing.

  4. Mateofloyd

    Mar 20, 2023 20:49

    Even tho that I tried cleaning the cache I still have the same problem

  5. MattuWalk

    Mar 06, 2023 11:16

    TWENTYEDGES solution worked for me! Thanks

  6. TwentyEdges

    Feb 27, 2023 11:29

    i had the same issue after updating OSX to Ventura.

    For me a simple Unity cache clean worked. Go to Preferences -> GI Cache -> Clean Cache.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.