Search Issue Tracker

Fixed in 2020.3.X

Votes

16

Found in

2020.3.24f1

2020.3.25f1

Issue ID

1390097

Regression

Yes

Specific Actions dropdown tab does not appear when setting the Target of the Touch Trigger in the LEGO Template

Templates

-

How to reproduce:
1. Open the user attached project
2. Enter the "LEGO Tutorial" Scene found in the Scenes folder (Assets -> LEGO -> Scenes)
3. Double click on the "Altar" Prefab GameObject in the Hierarchy
4. Press on the yellow "Touch Trigger" Prefab GameObject
5. Change the Target of the "Touch Trigger Script" Component in the Inspector to "Specific Actions"

Expected result: A modifiable dropdown tab appears
Actual result: No modifiable dropdown tab is visible

Reproducible with: 2020.3.24f1
Not reproducible with: 2019.4.34f1, 2020.3.23f1
Couldn't test with: 2021.2.7f1, 2022.1.0b2 (No LEGO Template)

Note:
- Reproducible on a new LEGO Template project

  1. Resolution Note (fix version 2020.3):

    Fixed in: LEGO® Microgame v2.4.2

Comments (18)

  1. theqpowerrr

    Feb 07, 2022 21:12

    I also had this issue, but I followed user A30_CREATIVE solution and it worked.
    Thank you!

  2. a30_creative

    Feb 05, 2022 18:46

    Had the same error, and SCHNUFFELDUFFEL's fix worked fine.
    In a nutshell (coz concise is the name of the game here):

    No need to close the Unity editor. The change you make will be detected and implemented automatically.
    Use your folder search tool and find 'triggereditor.cs'.
    Open that file in your favourite editor, e.g. VS Code.
    Search the code for 'specific actions'. For me, the code in question was on line 72.
    Change the 'false' to 'true' a the end of the line.
    Save the file.
    The foldout arrow will magically appear next to 'Specific Actions'.

  3. ToynLee

    Feb 05, 2022 05:03

    Same issue in 2020.3.26f1ci

  4. extremegamingnow

    Feb 04, 2022 03:47

    I've replaced the code that SCHNUFFELDUFFEL supplied, but now I get errors and can only enter in "safe mode". Really hope this gets resolved fast because I had so much fun!

  5. cottenmouthz

    Feb 04, 2022 00:29

    Thanks SCHNUFFELDUFFEL, This fixed my problem, but I had to find the right duplicate lEGO tutorial folder and change the one that unity was choosing to open every time I would click All Tutorials. for me there were 8 different randomized number folders after the Temp folder, such as
    b165562e8ee4796478872df3034b3271,-----, b12c71f6b74e5394da191e2d4afae3a8, -----,50c96020408c2454a9249355db828675. Not sure why this is(Perhaps because I had opened the Tutorials many different times from the Unity Hub and it created a new LEGO project folder for each one instead of opening the same one each time? No idea, just getting into learning unity and C# programming.

    Thanks again for the fix!

  6. Anunitu

    Jan 19, 2022 05:16

    update: tried a new project. Explode block is fine, but the fix didn't work for me sadly

  7. Anunitu

    Jan 19, 2022 04:04

    I tried Schnuffelduffel's solution and it broke the explosion block tutorial. I literally just started learning so idk what to do

  8. Abdulla525

    Jan 17, 2022 04:23

    I sorted out the bug issue exactly as @SCHNUFFELDUFFEL said.
    Many Thanks :)

  9. Abdulla525

    Jan 16, 2022 19:16

    im having the same issue with version 2020.3.26f1. please advise what to do? it seems i cant complete the tutorial without solving it

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.