Search Issue Tracker

Fixed in 2018.3

Votes

0

Found in

2018.3.0a7

Issue ID

1066979

Regression

No

Package manager UI package can be downgraded to incompatible version when downgrading to two oldest available versions

Packman

-

How to reproduce:
1. Create a new project
2. Navigate to Package Manager
3. Find Package Manager UI package and downgrade it to last or second to last version
4. In the Package Manager UI package observe all other versions which are incompatible and were not there prior to the first downgrade

Expected result: Package Manager UI does not show incompatible versions as a possible downgrade
Actual result: Package Manager UI does show incompatible versions as a possible downgrade

Reproducible with: 2018.2.2f1, 2018.3.0a7

Note: 2018.1.9f1 does not let you upgrade or downgrade Package Manager UI through Package Manager window

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.