Search Issue Tracker

Not Reproducible



Found in



Issue ID




Missing Namespace UI error appears when a script tried to use UnityEngine.UI



After running through a few packages in the Assets Store, loading and unloading packages and DLLs, I got into a state with my project when Unity doesn't recognise "using UnityEditor.UI" in all the scripts in the Google Cloud Vision project.

This does not happen when i freshly install the Google Cloud Vision asset in a fresh new project.

To reproduce the error in the console:
- download this project
- open it with Unity 2019.2.0b3 or 2019.3.0a3 on Windows 10
- notice the compilation errors:
Assets\FrostweepGames\GCSpeechRecognition\Examples\Example\Example.cs(4,19): error CS0234: The type or namespace name 'UI' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?)

Reproduced with Unity 2019.2.0b3 and 2019.2.0a3
Cannot reproduce in Unity 2019.1.0f2, 2019.3.0a2, 2019.2.0a14

Comments (53)

  1. A72baba0e25667cea95537b83c8d4d10?d=mm


    Mar 27, 2020 13:02 Yeezy Supply Pandora Yeezy Air Force 1 Nike Air Force 1 Nike Air Max 270 Kobe Bryant Jersey Kobe Bryant Jerseys For Sale Kobe Bryant Jersey 24 Kobe Bryant Website Official Pandora Bijoux Yeezy Yeezy Yeezy Shoes Nike Shoes NFL Jerseys Yeezy Boost 350 Yeezy Yeezy Shoes Yeezy Yeezy Yeezy 350 Yeezy Yeezy Shoes Adidas Yeezy Yeezy 700 Yeezy Boost 350 V2 Nike Outlet Yeezy Shoes MLB Shop Adidas Yeezy MLB Jerseys Yeezy 380 Yeezy 380 Nike Outlet Human Races Human Race Shoes Uggs Official Site Pandora Basketball Jerseys Basketball Jerseys Cheap NBA Jerseys Nike Outlet Pandora Canada Pandora Charms Pandora Jewelry Pandora Outlet Pandora Jewelry Official Site MLB Jerseys Pandora Pandora Bijoux Adidas Yeezy Pandora Soldes 2020 Yeezy Shoes Yeezy Mafia

  2. C8d8c4442cfad51be698cf8b1029d140?d=mm


    Mar 24, 2020 11:56

    BTW - Manually forcing an upgrade of Visual Studio Code Editor package to 1.2.0 seems to have solved the problem

  3. C8d8c4442cfad51be698cf8b1029d140?d=mm


    Mar 24, 2020 11:14

    I just got this as well - 2019.3.6f1 was working OK until I installed a new package and then - bam!

  4. Cb8a7b97d5eebf9e1bbe6e097b24fcce?d=mm


    Mar 22, 2020 06:06

    Same problem here, but I managed to solved it (at least for now). I did what BENFC1993 said, also did this: (downgrade the version of the Visual Studio Code Editor package), but even all that didn't fix it. So, I downgraded the version of the TextMeshPro Package as well (to 2.0.0), removed it, removed the Unity UI package, and reinstalled both. And after painful minutes, it was all working again. Hope to help someome. I was using version 2019.3.6f1 of Unity.

  5. 4d807c8ef7c57dc78271a8d1aade5831?d=mm


    Mar 17, 2020 06:03

    I have the same issue in 2019.3.0f6 PLEASEEEE!!!!

  6. 65d9e53cd25882c7993e4461a305026d?d=mm


    Mar 06, 2020 19:44

    All you need to do to fix this is got to Edit > Preferences > External Tools make sure the 'Generate all .csproj files.' is checked the in your IDE delete the:


    files in the root of your project.

    Close and reopen vscode.

  7. 92f2a4937e3b3e5a060e948d46488268?d=mm


    Feb 21, 2020 22:51

    I installed UnityEngine.UI with Nuget from Visual Studio

    This solved it for me.

  8. 6093cdeac08d162c5dd5089762c3c0d9?d=mm


    Feb 09, 2020 14:57

    I can confirm the same issue going from 2019.2 to .3. The workaround referenced at worked for me as well.

  9. 0efccffcff4a578829abf9b6179f198e?d=mm


    Feb 06, 2020 09:38

    Also in the release 2019.3 - here is a quick workaround -

  10. 390dd9dc4ba93548f2d18409900001a3?d=mm


    Feb 04, 2020 14:56

    Same issue on 2019.3.0f6.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.