Search Issue Tracker

Fixed in 2020.2

Fixed in 2019.4, 2020.1

Votes

0

Found in

2019.3

2019.3.9f1

2020.2

Issue ID

1237217

Regression

No

[macOS] .bundle plugins are not linked on Xcode project export

MacOS

-

Reproduction steps:
1. Open project in "nativePluginOSX2.zip"
2. Build for Standalone (make sure "Create Xcode Project" is selected in Build Settings)
3. Deploy the project
4. Function testMethod(); will be called from a Plugin and the result displayed
5. Inspect the Text field

Expected result: Text field contains "3" (returned from testMethod(); PluginImport.cs line 17)
Actual result: Text field contains "System.DllNotFound exception..." which is thrown at testMethod();

Reproducible with: 2019.3.14f1, 2020.1.0b8, 2020.2.0a12
Could not test with 2018.4 because Xcode builds for Mac are not supported

Tested with macOS 10.15.3 Catalina

Note: building fails in earlier versions in some streams because of "Command /usr/bin/codesign failed with exit code 1" error in Xcode

  1. Response avatar

    Resolution Note (fix version 2020.1):

    Fixed in 2020.1.1f1.4251

  2. Response avatar

    Resolution Note (fix version 2019.4):

    Fixed in 2019.4.8f1 (60781d942082)

Comments (2)

  1. 609760b7f8b4a76223898ed579ff6580?d=mm

    NapsTeam

    Sep 22, 2020 20:15

    it is fixed on 2019.4.8f1, but it's still not linking plugins on 2020.2.0b2

  2. 94bf64f5bacf750f21913ad404945612?d=mm

    Numa

    Jul 31, 2020 00:18

    Do you have an estimate for which 2019.4 version will get this fix?
    Thanks!

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.