Search Issue Tracker

Fixed in 2019.3.X

Fixed in 2019.1.X, 2019.2.X

Votes

1

Found in

2019.1

2019.1.0b9

Issue ID

1139545

Regression

Yes

Editor crashes on selecting shader dropdown in the inspector after packages are removed from the project

Graphics - General

-

Editor crashes on selecting shader dropdown in the inspector after resetting package to default

Steps to Repro:

1. Create a new project with LWRP Template
2. Go to Help > Reset packages to defaults
3. Select "Drywall Panel" GameObject in the Hierarchy
4. Go to Inspector > Mesh Renderer > Click on Shader dropdown

Expected Result: Shader dropdown opens
Actual Results: Editor Crashes

Occurring on : Windows 10

Reproducible on : 2019.1.0b9, 2019.1.0b8, 2019.1.0b7, 2019.1.0b6, 2019.1.0a1
Working Fine on: 2019.2.0a9, 2018.3.0f2

Comments (7)

  1. 3d331d7a2610964fd6a2ec8179078ecc?d=mm

    DanjelRicci

    Mar 14, 2021 13:05

    This problem appeared in my project after upgrading from 2020.2.0 to 2020.2.7. Every time I choose a shader from the dropdown in the Material properties, the editor hangs for some seconds. Solved with the solution wrote by Valiz, thanks.

  2. 79a1cc6db9b4deed0a6763a46470aea0?d=mm

    RHPOSITIVE

    Mar 02, 2021 12:17

    There is still the problem (2020.2.6f1) This issue didn't exist until I started working with Shader Graph. Now I deleted the ShaderCache clapper and the ShaderCache.db (6.7GB) file as Valiz wrote and it was fixed.

  3. 25e844c0d1c9f833acd1d7db50ab3713?d=mm

    DigitalIPete2

    Feb 25, 2021 13:10

    Im pleased to find a solution to this for 2020.2.6f1 - Valez thanks - Im going to try that on my project.

    This issue is certainly not fixed.

  4. 50f78ecfb9c84d2ddffc2c16e59fb66e?d=mm

    ValiZ

    Feb 20, 2021 16:34

    Hello! I don't know if this is the same problem, but i had unity always freezing when tried to select the shader dropdown.
    What worked for me was to go into my project folder/Library and delete the file called ShaderCache.I dind't knew why my project was getting so big every time, without adding any new assets or when in fact my project is a small one.Looks like the ShaderCache file was geeting bigger every time when i tried to modify a material, it was 14gb.After deleting that, unity works normally and i am able to change the materials or shaders properties as usual.

  5. 199023279e01249da9390d77a272c7ad?d=mm

    MarshallVisions

    Jun 21, 2019 09:02

    I'm having the same problem in 2018.3.14

  6. 50585df2acced0606077744a17f903db?d=mm

    Eloujah

    May 23, 2019 10:02

    The same with me, but with HDRP

  7. 4a10e4a8a7f8598172e65d3120d02647?d=mm

    BenR

    Apr 02, 2019 21:43

    Seeing similar with Mac. Was running LWRP and tried to change shader. Even creating new material and selecting shader dropdown leads to instant crash.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.