Search Issue Tracker

Fixed in 2022.2.X

Fixed in 2021.3.X, 2022.1.X



Found in







Issue ID




Editor crashes at "__assert_fail_base.cold" when opening a project (Linux)



How to reproduce:
1. Create and open a new project
2. Observe the crash

Reproducible with: 2019.4.31f1, 2020.3.21f1, 2021.1.27f1, 2021.2.0f1, 2022.1.0a12

1. Reproducible on Ubuntu 20.04 and 18.04
2. Not reproducible on Windows 10
3. Likely caused by running Mesa driver versions 21.0.0 and newer and using the OpenGL graphics API
4. Does not reproduce on Nvidia GPUs

  1. Resolution Note (fix version 2022.2):

    Currently, we are still investigating this issue. At the moment, these options are available for people experiencing this crash:
    - Waiting for the fix to land;
    - Switching to an OS that does not reproduce this issue (macOS and Windows);
    - Installing a dedicated GPU on your system (not possible for those using a laptop);
    - Downgrading Mesa drivers to be older than version 21.0.0.

    Additionally, some people have reported that forcing Unity to run with the -force-vulkan flag bypasses the crash.

    The crash is caused by a bug in the MESA drivers. There's already a fix in progress ( and currently, it's waiting to land in the main MESA branch.

    Fixed in 2022.2.0a12

  2. Resolution Note (fix version 2022.1):

    Fixed in 2022.1.1f1

  3. Resolution Note (fix version 2021.3):

    Fixed in 2021.3.3f1

Comments (14)

  1. pzl_4

    May 02, 2022 11:31

    From what I can see, you need these command line arguments:
    For those who don't know, to add these you need to go to the project in the hub, click the ellipsis and select 'Add command line arguments'. Then copy and paste the arguments above and save.

  2. Steedalion

    Mar 07, 2022 08:56

    Yo boy presented the best solution I have seen for now.

  3. Steedalion

    Mar 03, 2022 23:47

    Installing nvidia drivers solved the issue for me but caused a number of visual artifacts.

  4. mr_popo

    Mar 03, 2022 05:33

    Just an update. The -force-glcore only worked once... When I went to change the game view resolution Unity crashed out and wouldn't open again. I went ahead and added NVIDIA drivers instead and that has solved them problem.

    Run this in your terminal to install the drivers (for Ubuntu based OS):

    sudo apt install software-properties-common -y
    sudo add-apt-repository ppa:graphics-drivers/ppa -y
    sudo ubuntu-drivers autoinstall

  5. mr_popo

    Mar 02, 2022 05:20

    I've had the same issue with the MESA drivers update recently. The -force-vulkan didn't work for me but -force-glcore did.

    In the Unity Hub if you click on the ellipsis button '...' to the right of your project and select 'Add command line arguments' you can add -force-glcore there. The Editor loads fine and the game builds with no problems either. Hope this helps.

  6. alexanderburgos819

    Mar 02, 2022 00:18

    I have the same issue but before that I had been using Unity with not problem and one day couldn't open any project

  7. NekoTheFox25

    Feb 18, 2022 05:46

    i got unity to work by using proprietary nvidia drivers, so sad we can't use open source drivers :(

  8. MasterKitty2006

    Feb 14, 2022 17:43

    I had luck with forcing Unity to run with the -force-vulkan flag. I also had -noUpm in there, but it started working after I added -force-vulkan.

  9. Runeru

    Nov 27, 2021 09:20

    Got a mail where they said this:

    The issue stems from the fact that your system has no dedicated GPU and thus you are by default using Mesa graphics drivers. More specifically, Mesa drivers version 21.0.0 and up (21.1.8 in your specific case).

    Currently, our developers are still looking into fixing the issue. Thus at the moment, you have these options:
    - Waiting for the fix to land;
    - Switching to an OS that does not reproduce this issue (macOS and Windows);
    - Installing a dedicated GPU on your system (not possible if you are using a laptop, unfortunately);
    - Downgrading Mesa drivers to be older than version 21.0.0.

  10. Mr_Nibbles

    Nov 23, 2021 15:18

    I managed to get around this error by making sure I was using proprietary nvidia drivers and rebooting.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.