Search Issue Tracker

Fixed in 2.6.10

Votes

0

Found in [Package]

2.6.9

Issue ID

1359831

Regression

Yes

Cinemachine internal code error "CS1513: } expected", when switching from 2.6.5 to 2.6.9 versions

Package: Cinemachine Classic

-

How to reproduce:
1. Open the attached project "Prj3.5.zip"
2. Open the Package Manager window
3. Change Cinemachine to 2.6.5
4. Change back Cinemachine to 2.6.9

Expected result: No errors
Actual result: An error is thrown

Reproducible with: Cinemachine 2.6.9 (2019.4.30f1, 2020.3.18f1, 2021.1.20f1, 2021.2.0b10, 2022.1.0a7)
Not reproducible with: Cinemachine 2.6.5, 2.6.10

Note: In some versions of the Unity Editor, you can't change the version in the package manager, do that by going into Manifest.json in the packages folder of the project

  1. Response avatar

    Resolution Note (fix version 2.6.10):

    Fixed in: 2.6.10

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.