Search Issue Tracker

Won't Fix

Won't Fix in 5.6, 2017.1

Votes

1

Found in

5.6.0f3

Issue ID

912361

Regression

No

[iOS] .xcworkspace isn't generated for iOS projects using Firebase plugin

iOS

-

When generating iOS builds headlessly, pods are not installed in the build folder when Firebase plugin is used.

Steps to reproduce:
1) Open the project in Unity - you will be prompted to switch to full .NET compatibility - agree and quit Unity.
- Optional: build the project via some/build in the Menu bar. Open the build folder - notice that there's a .xcworkspace file. Delete the build.
2) Open Terminal.
3) Build the project in headless mode with the following command:
/Applications/Unity5.6.0f3/Unity.app/Contents/MacOS/Unity -quit -nographics -batchmode -projectPath /Users/<yourUsername>/Downloads/BuildPodTest/ -buildTarget iOS -executeMethod TestPostProcess.PerformIOSinHouseBuild
4) Open the build folder (located in BuildPodTest/iOS).

.xcworkspace file should be generated, including all the necessary Firebase plugin dependencies. However, there is no such file present. This file does appear when building normally via the Editor (using some/build in the Menu bar).

Reproduced on:
2017.1.0b6, 5.6.0f3, 5.5.0f3

Comments (4)

  1. 8a93aa063b66aea6bc995d8d3d22f840?d=mm

    SirKnightDragoon

    Mar 02, 2019 04:06

    I fix it with install/update cocoapods manualy in my Mac OS.

    - Open Terminal.
    - Enter 'sudo gem install cocoapods' command in terminal.

    - Rebuild your app from Unity
    - Now XCWORKSPACE is here :)

  2. 39d01f6de65c6dd528a30412818851d3?d=mm

    dokyo

    Nov 27, 2018 05:03

    hi, arrive here very late, my case, I change PATH environment to change ruby path to run fastlane correctly, and this is the issue. seems some external tool that unity editor use, failed by this PATH change. hope it would help you.

  3. 522b2bda9baa0efdd012f0b68efdb1a7?d=mm

    ChrisCF

    Jul 20, 2017 21:27

    The following suggestion from https://groups.google.com/forum/?utm_medium=email&utm_source=footer#!topic/firebase-talk/AVdYYFFVYFg from the Firebase google group worked for me.

    Added the following at the start of my build function:

    EditorUserBuildSettings.SwitchActiveBuildTarget(BuildTargetGroup.iOS, BuildTarget.iOS);

  4. 522b2bda9baa0efdd012f0b68efdb1a7?d=mm

    ChrisCF

    Jul 19, 2017 22:13

    Also reproduced on 5.6.1p3

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.