Search Issue Tracker

Fixed

Votes

5

Found in

2.0.0

Issue ID

1193868

Regression

Yes

[Hub] [Linux] Cannot run Hub as Glibc 3.4.20-21 is required but unavailable in CentOS 7

Hub

-

[Hub] [Linux] Cannot run Hub as Glibc 3.4.20-21 is required but unavailable in CentOS 7

As of Hub 1.3.3, the Linux native implementation requires Glibc 3.4.20/3.4.21. As these versions of Glibc are currently unavailable in CentOS 7, the hub cannot be run, reporting the following errors to log:

{"level":"error","message":"Unhandled promise rejection, reason: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /tmp/.org.chromium.Chromium.IGPlEb)\n\tstack Error: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /tmp/.org.chromium.Chromium.IGPlEb)\n at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:172:20)\n at Object.Module._extensions..node (module.js:598:18)\n at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:186:18)\n at Module.load (module.js:503:32)\n at tryModuleLoad (module.js:466:12)\n at Function.Module._load (module.js:458:3)\n at Module.require (module.js:513:17)\n at require (internal/module.js:11:18)\n at Object.<anonymous> (/tmp/.mount_UnityHE6XpQi/resources/app.asar/node_modules/@unityhub/unity-editor-license/license.js:1:170)\n at Object.<anonymous> (/tmp/.mount_UnityHE6XpQi/resources/app.asar/node_modules/@unityhub/unity-editor-license/license.js:29:3)","timestamp":"2019-10-24T14:54:28.315Z"}

Steps to reproduce:
1) On a machine running CentOS 7, install or upgrade the latest Unity Hub (1.3.3+)
2) Observe the Hub will fail to launch and note the Glibc errors reported to the log at /home/teddy.kardos/.config/UnityHub/logs/

Comments (2)

  1. 715a4c00a8d3a0ee7371500d4c9e8346?d=mm

    Ross_94

    Oct 24, 2019 20:25

    also wanted to add that it occurred after updating to Unity Hub 2.1.3

  2. 715a4c00a8d3a0ee7371500d4c9e8346?d=mm

    Ross_94

    Oct 24, 2019 20:22

    Not sure why they did this, trying to download necessary libstdc++ 4.9 shared library in order to get around this issue, but this definitely an annoying issue that never should have occurred cant even do a simple yum install of the libraries since 4.8.5 is the latest one in centos 7 non scl repos.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.