Search Issue Tracker

Fix In Review

Votes

32

Found in [Package]

13.1.1

Issue ID

1379350

Regression

Yes

[HDRP] Render Graph execution error on "RenderPass Render Shadow Maps was not provided" after leaving editor open for a while

Package: Scriptable Render Pipeline HD

-

Steps to reproduce:
1. Open attached project and make sure paths point to your local Graphics repo
2. Open ReproRendergraph.unity
3. Leave the editor open for an hour or two
4. Observe that Render Graph execution error appears

Expected result: Render Graph execution error on "RenderPass Render Shadow Maps was not provided" should not occur

Comments (19)

  1. 8fb9f8508c30e3dd78585ce19516e7f9?d=mm

    BrianWhitenack

    Jan 04, 2022 04:35

    Please fix this asap. It happens every 5 minutes of editor use.

  2. B775462ac046f4a79fbd57b78ebcdd79?d=mm

    maxdesmo

    Dec 28, 2021 05:14

    @Seith Thanks, I tried you're method and it worked for me. I was previously getting the error after 5 minutes in play mode. I can now run it for more than 30 mins without issue, so the fix posted by @SebLagarde does appear to have fixed the issue (at least for me).

  3. 77ffae68520cdb519671c8052e9aee69?d=mm

    Laruda

    Dec 26, 2021 02:11

    When are we going to have a fix? I can't work on my project because of this bug

  4. 30ecc52fbe6803584958083069685ed2?d=mm

    colinleet

    Dec 22, 2021 21:41

    This bug blows up my game every 5-10 minutes, needs a full restart. Unavoidable =(

  5. 3018f0fcce749ccadcadf585e62115d2?d=mm

    Seith

    Dec 17, 2021 08:13

    @Maxdesmo You need to delete the directory of the cached version from your project's Library folder (ie. [yourGame]\Library\PackageCache\com.unity.render-pipelines.core@12.1.2\Runtime\RenderGraph) before you modify the file in your Unity install folder.

    By modifying the RenderGraphResources.cs file in C:\Program Files\Unity\Hub\Editor\2021.2.6f1\Editor\Data\Resources\PackageManager\BuiltInPackages\com.unity.render-pipelines.core\Runtime\RenderGraph it will force Unity to recreate the cached version in your project, but this time it will include the fix you put in.

  6. 8bc574aeb2c4f916c18eacfa976b9c7d?d=mm

    Matjio

    Dec 16, 2021 09:25

    Here are some instructions on how to modify source code: https://github.com/Unity-Technologies/Graphics

  7. 8aadef87bee3a81b6e1555b605584d43?d=mm

    VARtechLLC

    Dec 16, 2021 01:54

    It doesn't seem to fix it for me. I still receive the error after messing with textures and materials randomly, very frustrating.

  8. B775462ac046f4a79fbd57b78ebcdd79?d=mm

    maxdesmo

    Dec 16, 2021 00:10

    How do I modify the package source code with the provided fix? I tried doing this manually, but I get the following:

    The package cache was invalidated and rebuilt because the following immutable asset(s) were unexpectedly altered:
    Packages/com.unity.render-pipelines.core/Runtime/RenderGraph/RenderGraphResources.cs

    It appears the package is not editable

  9. 8f6260da980f70ca7bf08059bc33c7f8?d=mm

    SebLagarde

    Dec 15, 2021 18:30

    Hi, thanks for reporting this issue, it is fixed but we have experienced slowness in getting result in an official release. Should be in 2021.2.8f1 or 2021.2.9f1.
    Fix is here in case you can afford to modify package source code until getting official release: https://github.com/Unity-Technologies/Graphics/pull/6329/files

  10. 53ea362d979aab97543e1b262cecb533?d=mm

    MGC_Marc

    Dec 15, 2021 16:37

    The error seems to be gone by deleting the planar reflection probe from my scene and relaunching the editor...

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.