Search Issue Tracker

Fixed in 2.5.5

Votes

1

Found in [Package]

2.3.0-preview.3

Issue ID

1304944

Regression

Yes

Error appears when installing Unity Recorder package on Windows with Target Platform set to Mac OS X

Package: Recorder

-

Reproduction steps:
1. Open the attached project (on Windows)
2. In the Build settings, set Mac OS X as the Target Platform
3. Import Unity Recorder package

Expected result: The package is imported without errors
Actual result: Error appears in the Console window

Reproducible with: 2.3.0-preview.3 - 2.5.4 (2018.4.32f1, 2019.4.20f1, 2020.2.5f1, 2021.1.0b7, 2021.2.0a5)
Not reproducible with: 2.0.0-preview.6 - 2.2.0-preview.4 (2018.4.32f1, 2019.4.20f1, 2020.2.5f1)

Notes:
1. Not reproducible on Windows with Windows Target Platform
2. Not reproducible on Mac OS with Mac OS X Target Platform
3. Reproducible on Windows with Mac OS X Target Platform
4. Error:
"Library\PackageCache\com.unity.recorder@2.5.4\Editor\ProRes\ProResEncoderPlugin.cs(346,51): error CS0117: 'ProResWrapperHelpers' does not contain a definition for 'SupportsCodecFormat'"

  1. Resolution Note (fix version 2.5.5):

    Fixed in Unity Recorder 2.5.5

  2. Resolution Note (fix version 2.5.5):

    Fixed in: Unity Recorder 2.5.5

  3. Resolution Note:

    Fixed in 2020.3.3f1

Add comment

Log in to post comment