Search Issue Tracker

Fixed in 2022.1.X

Votes

0

Found in

2019.4

2020.3

2020.3.12f1

2021.1

Issue ID

1345905

Regression

No

Editor is stuck on loading scripting assemblies when there is a .meta file of non existent asset and Asset Database V2 is used

Asset - Database

-

How to reproduce:
1. Extract and open attached project "game.tgz"

Expected result: Editor loads
Actual result: Editor is stuck on loading scripting assemblies

Reproducible with - 2019.4.28f1, 2020.3.12f1, 2021.1.14f1, 2021.2.0b1
Not reproducible (no Asset Database V2) - 2018.4

  1. Response avatar

    Resolution Note (fix version 2022.1):

    Fixed in 2022.1.0a6

Comments (2)

  1. E9a4c456373948d8f177962dc7e62967?d=mm

    racetrack

    May 11, 2022 06:29

    Don't know if this will be of use to anyone, but when I was getting frozen on reload script assemblies (infinitely frozen), I did a LOT of guess-and-checking, and found that deleting the UserSettings/Layouts/default-2021.dwlt in my project's folder solved the problem. I have no idea what that file is for or if I'm doing something bad by deleting it, but it works. If anyone can tell me what that file is for, I'd be grateful.

  2. 33d31fdaf0a63654166536250d70df9e?d=mm

    Lyrcaxis

    Jan 06, 2022 19:11

    This can also happen when there's an invalid link junction (one that points to a non-existing folder).
    It also comes with heavy disk usage, which is strange... I left it open for hours while waiting for the possibility it may resolve by itself.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.