Search Issue Tracker

Not Reproducible

Votes

8

Found in

2017.4

2019.2.6f1

Issue ID

1187248

Regression

No

Downloading Collab project has Hub warn about version not matching 5.0

Collab

-

1. What happened

When downloading a Collab project from the Hub, regardless of if the Editor version used to download it is the same or different than the project used, we get an "Opening Project in Non-Matching Editor Installation" message. It claims that the Saved Project used a version of Unity that was before 5.0, when that isn't the case.

2. How we can reproduce it using the example you attached
a) Open the attached project in any version of Unity past 2017.4.
b) Enable Collaborate and publish this project using the Collab Toolbar.
c) Delete the project from your machine, then redownload it from the Hub.

Expected: If the version of Unity matches that of the project then there should be no Editor Mismatch error. If the versions are different, then the Saved Project field should be accurate to the version of Unity that was used to publish the project and not say it was before 5.0.

Actual: See attached EditorMismatch.png screenshot.

  1. Response avatar

    Resolution Note:

    Does not reproduce using Unity Hub 2.3.0.

Comments (4)

  1. Fd6463bc586872f2507895ebf3a7ce0f?d=mm

    contactjakemb

    Feb 29, 2020 16:27

    2019.2.17f1. I'm trying to download my project from Unity Collaborate on mac OS. My unity hub says my project was last updated 6 days ago, when it was actually updated like an hour ago?? My project folder that has been downloaded though but only contains an empty Assets folder and an empty Library folder. It also has a Project settings folder containing only ProjectVersion.txt. This file contains the following: "m_EditorVersion: UnknownUnityVersion \n m_EditorVersionWithRevision: UnknownUnityVersion". Also has a temp folder with a unity lock file.

  2. 631ef0710ce8629e40788b3c87630faa?d=mm

    martin_orav

    Jan 05, 2020 13:30

    I also have this issue on 2019.2.17f1.

  3. 5dfdbeb23620dd3461c54db08992982b?d=mm

    Realillusions

    Dec 09, 2019 21:49

    Hi, same problem with me with : 2019.2.14-15f1.

  4. D3e82e6a007783c51dc2bacf8c0d7ed7?d=mm

    Clonkex

    Oct 12, 2019 05:33

    I also see this issue. I'm amazed there's not more votes.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.