Search Issue Tracker

Fixed in Unity 2017.2.0f3

Votes

7

Found in

2017.1.0f3

Issue ID

931944

Regression

Yes

AssetDatabase.GetSubFolders does not work at all since 2017.1

Scene Management

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Workaround is possible

Repro: Run attached editor tests on 5.6 and 2017.1, note that:

1. The documentation is incorrect, it suggests that we accept absolute paths (not the case, in 5.6 or 2017.1)
2. The feature has stopped working at all since 2017.1

Regression introduced in - 2017.1.0a1
Reproducible with - 2017.2.0b3, 2017.1.0f3,
Not reproducible with - 5.6.2p4, 5.5.4p2

Fixed in: 2018.1.0a2, 2017.3.0b5, 2017.2.0p1, 2017.1.2p1

Comments (7)

  1. 5b27b37e5db0b71ca3a9a9538d6e04a3?d=mm

    AntonQvarfordt

    Nov 16, 2017 19:30

    Still not working for me with 2017.2.0f3

  2. 503658e35569646994bb3b377852d90a?d=mm

    Jinl

    Oct 26, 2017 19:01

    not fixed in 2017.2.0f3 on Sierra platform. Using alternative System.IO method

  3. E43fc25c0aa27eed84751d2b6eca5241?d=mm

    hd-wooga

    Oct 16, 2017 08:16

    Fixed in 2017.1.2p1

  4. B1d4bcdc0272de6a23bfad28765d23cc?d=mm

    Jaacob

    Oct 15, 2017 14:11

    Same in 5.6.2p3.
    Tried project folder, Application.dataPath, absolute path, slashes and backslashes, empty path, all combined, didn't get any result whatsoever. Seems the method only returns string[0].

  5. 6db700bbcfb1d7e6ae24f2864d65ac87?d=mm

    allenwp

    Aug 22, 2017 21:26

    Yep. Using System.IO.Directory.GetDirectories instead as a workaround for now...

  6. E43fc25c0aa27eed84751d2b6eca5241?d=mm

    hd-wooga

    Aug 04, 2017 08:12

    Same here in 2017.1.0p2

  7. 38be89729fade0cddd610dfefc64fcae?d=mm

    xdegtyarev

    Jul 27, 2017 12:16

    Has same issue, it always returns 0 subfolders in list

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.