Search Issue Tracker

Fixed in 2018.3

Votes

0

Found in

2017.2.0f3

2017.3.0f3

Issue ID

993592

Regression

Yes

Applying a prefab throws NullReferenceException

Asset Import Pipeline

-

To reproduce:

1. Open the project, attached by the user (Assets.zip)
2. Open the "Menu" scene
3. Select Standard Scene Manager game object in the Hierarchy
4. In the Inspector, press Apply
5. Observe the console

Reproduced in 2017.2.0f3, 2017.2.1p3, 2017.3.0f3, 2018.1.0b5
Did not reproduce in 2017.1.3p1, 2017.2.0f2
Regression introduced in 2017.2.0f3

Comments (5)

  1. 89635cc344a54f1d44b00db5f07ea428?d=mm

    unity_VL7ALsn6f69AaA

    Sep 29, 2020 07:13

    I've stumbled on this to at one of my projects <betandslots.com I've solved it quite quickly at the time but don't ask me how! I totally forgot :)

  2. 5e5f67ca612093c9e0eaae560d6af3a1?d=mm

    HarleyKnight

    May 14, 2020 11:55

    When I was running this issue https://ipayzz.com/no-deposit-bonus-codes/ really helped me and cheer me up. It is so great when you have such bonuses to use for the game.

  3. 51c9d4d6fed368a883cb29323ecc511c?d=mm

    edwinmay

    May 15, 2019 06:45

    Note this issue is not only Editor related, we're also having this crash on iOS.
    https://run3az.com Reproduced in LTS Release 2017.4.0f1

  4. C7d2f76a6c430a9ad571a5ba9e45b0a4?d=mm

    LT23Live

    Jun 05, 2018 22:39

    I am running into this issue too. Alongside that, sometimes when we bring the prefab back in, the assets aren't in the applied position. This has only been tested with UI elements for the canvas.

  5. Cdcbee10f59a083473407529e8a8e08d?d=mm

    ForteBass

    Feb 16, 2018 23:42

    I encountered this too. Worked around it by dragging the affected hierarchy member onto the existing prefab of that object.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.