Search Issue Tracker

Fixed in 2019.1

Fixed in 2017.4, 2018.3

Votes

0

Found in

2019.1.0a6

Issue ID

1094262

Regression

Yes

[Android] One gets popup about "outdated Android SDK" when both 28.0.1 and 28.0.3 exist

Mobile

-

How to reproduce:
1. Create a new project
2. Switch to Android player
3. Build Android project
Result: While building you get "Android SDK is outdated" popup. It states that SDK build tools version is 28.0.1 < 28.0.3
4. Click on Update Android SDK
Result: after few seconds you get same popup

Note: I have all of these Build Tools: 28.0.1, 28.0.2, 28.0.3. I have latest SDK android-28. So issues are two: 1. Why do I even get this popup? 2. It updates and returns to the same window

Reproducible: 2019.1.0a6
Not reproducible: 2019.1.0a5

Comments (3)

  1. 5fe1140447de4eec854fa33d1027265e?d=mm

    ciftciMert

    Jul 04, 2019 07:06

    Check your android manifest file

  2. 7b0e23c1517bce5eed15e6b4555d9395?d=mm

    Unity_Ride

    Apr 01, 2019 06:53

    when open project setting at issue occure

    "Failed getting available Android API levels. Make sure your android sdk tools version is 25 or higher and you have internet connection.
    System.Threading.ThreadHelper:ThreadStart()"

  3. 3a946b260905e8e555e42eeef20d3d32?d=mm

    ValdecoTFG

    Feb 01, 2019 15:37

    Also reproducible on 2017.4.19f1 LTS version

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.