Search Issue Tracker

Fixed in 2019.2.X



Found in


Issue ID




[Android] Unable to load or use keystore with password due to incorrect storepass parameter quoting



Steps to reproduce:
1. Use keytool.exe to create a keystore with a password, and a key with the a password
2. Load Unity and set it to use the built-in open-jdk implementation
3. In Unity's Android Player settings, select this keystore, or enter the Keystore Manager and select the keystore
4. Enter the password for the keystore (or in the Keystore Manager, enter the password and select Load Keys)
5. Receive an error - Unable to list keys in the keystore. Please make sure the location and password of the keystore is correct.
6. Note in the error message that the -storepass argument passed to keytool.exe is the password you provided (e.g. foo_bar) but quoted using single-quotes (e.g. -storepass 'foo_bar')
6 Run cmd.exe and copy the command line from the error message and run it, receive an error
7. Remove the single-quotes from the -storepass argument, run it again, see that it works

Expected result: storepass parameter should not be quoted

Reproduced in: 2019.3.0a1, 2019.2.0a1
Not reproduced in: 2019.1.0f2, 2018.3.14f1
Regression since: 2019.2.0a1

Comments (3)

  1. comitodan

    Jul 31, 2022 18:31

    Sorry ;) below solution, on unity 2021.3.6

  2. comitodan

    Jul 31, 2022 18:30

    I tried the above solution but the value is already blank

  3. sanjay_soni

    May 22, 2020 12:57

    SOLVED :-
    1. Goto root of your project where you can see Assets and ProjectSettings Folder
    2. Goto ProjectSettings -> Open ProjectSettings.asset in and editor like Notepad++ or VS code.
    3. Search - 'AndroidKeystoreName' and 'AndroidKeyaliasName' in that file
    4. replace with this OR just make the value blank

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.