Search Issue Tracker

Fixed in Unity 2017.1

Votes

16

Found in

5.6.0p2

Issue ID

904652

Regression

Yes

[Android] Performance regression when loading a prefab with a lot of child objects using Resources.Load()

Mobile

-

-

Priority: 2Necessary for shipping a final release

-

Severity: 3Workaround is possible

To reproduce:

1.Download and open attached "ResourcesLoadBugReport560p2.zip" project.
2.Build and run on Android device.
3.Open profiler in the editor and connect device.
4.Press "Resources Load" button.
5.Notice a load spike in CPU usage.
6.Inspect it and notice that under BehaviourUpdate | EventSystem.Update() | Loading.ReadObject a process named "Loading.ReadObjectThreaded" takes about 300~700 ms to complete.

Expected result: Load time to be about 40~50 ms.
Actual result: Load time is around 300~700 depending on a device.

Reproduced with: 2017.1.0b2, 5.6.0p3
Not reproduced with : 5.5.3p2, 5.4.5p1

DUT:

Verizon SM G930V (Galaxy S7 Verizon), OS:7.0, CPU:arm64-v8a, GPU:Adreno (TM) 530, Build:Verizon/heroqltevzw/heroqltevzw:7.0/NRD90M/G930VVRU4BQA2:user/release-keys

Sony D6603 (Xperia Z3), OS:6.0.1, CPU:armeabi-v7a, GPU:Adreno (TM) 330, Build:Sony/D6603/D6603:5.1.1/23.4.A.1.264/2418263178:user/release-keys

Samsung SM G361F, OS:5.1.1, CPU:armeabi-v7a, GPU:Vivante GC7000UL, Build:samsung/coreprimeveltexx/coreprimevelte:5.1.1/LMY48B/G361FXXU1APB1:user/release-keys

Notes: On 2017 version, the ms seems to fall to around 100 ms, but this is still 2x slower than in 5.5 or 5.4. Prefab has around 650 child objects

Verified with 2017.2.0b2

Comments (25)

  1. 3dbfe0b51bd41ba4cf7b0a4a9c543675?d=mm

    sfilo

    Nov 07, 2017 17:49

    Using Unity 2017.1.2.f1 and IL2CPP makes the load time faster but it's still at least 4 times slower than the iOS load time.

  2. 8f79516d2eb398f0108129a7d81ec29e?d=mm

    amjaliks

    Nov 06, 2017 13:00

    Same here. Tried 2017.1.2f1 and 2017.1.2p2. The issue persists.

  3. E8d7ad0bd9dfa9972a463c9a8b932f85?d=mm

    sourabhverma

    Oct 16, 2017 10:31

    This issue still exists in Unity 2017.1 . I am getting 10-20 secs in loading a single asset. Its a nightmare in android.

  4. B0bc1ea59f5d4a6be2e5c78646698777?d=mm

    dosantos_08

    Sep 26, 2017 10:39

    Same here! I am using v2017.1.0p5 and the bug is not fixed. Any idea if future versions fix that?

  5. C76e215620c5921028da271a114df893?d=mm

    elhispano

    Sep 26, 2017 10:31

    I can't vote because this issue is marked as fixed. ¿How can we communicate with Unity so they can reopen this bug?

    This is having a big impact in our release plan.

  6. A4bdc554f0314eae387424fdf700a524?d=mm

    GeneraGames

    Sep 26, 2017 10:30

    Hi Guys! Currently we can't release on Android because of this issue. After two weeks and two programmers we couldn't find a workaround.
    We have submitted a bug to Unity with an example project where we were able to reproduce the problem but we haven't got a response yet.

    Feel free to post your tests/conclusions in this post:
    https://forum.unity.com/threads/android-very-slow-loading-of-some-prefabs-in-2017-1.493092/#post-3229673

  7. 03ff34e358c22040210eca06b676b922?d=mm

    GeneraCrios

    Sep 26, 2017 10:29

    We are still facing this issue. Its not necessary that have a lot of child objects in our case.

  8. 225abb665ba6c50e7156c1652160150c?d=mm

    kokteylgaming

    Sep 25, 2017 14:53

    Still not fixed in Unity 2017.1.1 using Mono

  9. 4bb1ac48fb2ed573f7601ce9aee37ce1?d=mm

    samzgamz

    Sep 15, 2017 20:59

    The issue is marked fixed in 2017.1.1p1. I have tested it out and the performance is better but it is still not good enough. Time has reduced from more than 10 seconds but it is still taking 2-3 seconds where earlier it would be near instantaneous. Hope this issue is fixed completely soon.

  10. 4bb1ac48fb2ed573f7601ce9aee37ce1?d=mm

    samzgamz

    Sep 15, 2017 15:30

    Seeing the same issue in 2017.1 using IL2CPP. Tested on Moto G5s Plus.

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.