Search Issue Tracker

Fixed in 2022.1.X

Planned for 2019.4.X, 2020.3.X

Votes

21

Found in

2019.4

2020.3.15f1

2020.3.18f1

2021.1

Issue ID

1372558

Regression

Yes

[Android] 'Not enough storage space to install required resources' error when building App Bundle with Split Application Binary

Android

-

How to reproduce:
1. Download the attached project 'moonshades_mobile_bugreport.zip'
2. Build And Run on Android device
3. Close the app on an Android device
4. Build And Run on Android device

Expected result: App starts and 3 buttons can be seen on the screen
Actual result: An error window appears on the device screen saying 'Not enough storage space to install required resources'

Reproducible with: 2019.4.31f1, 2020.3.15f1, 2020.3.20f1, 2021.1.25f1
Not reproducible with: 2020.3.14f1, 2021.2.0b16, 2022.1.0a1, 2022.1.0a12
Could not test with: 2021.2.0a21 (Play Asset Delivery feature is not available)

Reproducible on:
VLNQA00022, Xiaomi Redmi Note 3 (Redmi Note 3), Android 6.0.1, CPU: Snapdragon 617 MSM8952, GPU: Adreno (TM) 510

Not reproducible on:
VLNQA00288, Samsung Galaxy J7 (SM-J730F), Android 8.1.0, CPU: Exynos 7 Octa 7870, GPU: Mali-T830
N/A, Huawei - (NOH-NX9), Android 10, CPU: NOT FOUND, GPU: Mali-G78
VLNQA00001, Google Pixel 2 (Pixel 2), Android 11, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540
VLNQA00316, Samsung Galaxy Note10 (SM-N970F), Android 9, CPU: Exynos 9 Series 9825, GPU: Mali-G76
VLNQA00225, Qualcomm null (SDM845 for arm64), Android 8.1.0, CPU: Snapdragon 845 SDM845, GPU: Adreno (TM) 630

Notes:
- Logs show no errors when the issue is reproduced
- Can be reproduced randomly by installing the app ~1/10 times (differs by Unity version and/or device)
- Does not reproduce with Default Compression Method (can be selected in Build Settings)

  1. Response avatar

    Resolution Note (fix version 2022.1):

    Fixed in: 2022.1.0a1

    Some users might still experience this issue (might be a different cause on some devices)

Comments (11)

  1. 9f340de5198384992f81889531bb34fa?d=mm

    Ommand

    Nov 18, 2021 11:19

    Will the fix be backported to at least 2021.2.x?

  2. 23ac56fab3559636c4f2a9c8a7ec9477?d=mm

    Rassalom

    Nov 12, 2021 14:24

    I hope it will be fixed asap... We simply can't update our game because of this issue.

  3. 3d9ae0c6bccae638388bcb7010d82493?d=mm

    KaOzz

    Nov 11, 2021 09:00

    Is this fixed?

  4. 7e935e32888c4dd70b98b9444e60f8f7?d=mm

    Bordousov

    Nov 08, 2021 13:07

    Still active on Pixel 3xl too

  5. 9678fc1edec6f0dbcd7ade72fc60b00e?d=mm

    androleocez

    Nov 08, 2021 10:44

    Still active on Google Pixel 3xl devices with Android 12

  6. 656e3365f7a8da3993d51ad3d9403955?d=mm

    Shisha_HWGuy

    Nov 08, 2021 10:42

    We have tried to use a fix from 2022.3.22. We have the following results.
    Redmi 9a - fixed
    Pixel 3XL - still active

  7. 0e4894e257900f01682192b04674f8e3?d=mm

    kbobnis

    Nov 02, 2021 15:51

    Also reproducible on 2021.1.27f1,

    ~1 out of 10 opens on One Plus 8Pro.

    Some times instead "not enough storage space to install required resources" error could be: "Unable to Initialize the Unity Engine".

    Logcat does not show information that I found useful in this case.

  8. 1c3219d96caed99e6c91da37efc16443?d=mm

    alexandr-bashkirev

    Nov 02, 2021 15:40

    We also tried Unity 2020.3.21f1 and still have this error.

  9. Ded58205fd1a8c76673da538fa924817?d=mm

    aurelienpic

    Nov 01, 2021 10:36

    We also have "Unable to Initialize the Unity Engine" with Unity 2020.3.15f2.
    We use "split application binary" with aab.

  10. 1c3219d96caed99e6c91da37efc16443?d=mm

    alexandr-bashkirev

    Nov 01, 2021 08:03

    We have same problem: errors "Unable to Initialize the Unity Engine" or "not enough storage space to install required resources" on some devices: Redmi 9A, Pixel 3XL, Samsung A52.
    Some times game is started but cant load the some resources. On other devices same build works fine.
    It started when we start use aab.
    We use addressables for resources.

    in logs we see:

    RemoteProviderException : TextDataProvider : unable to load from url : jar:file://!/assets/aa/settings.json
    UnityWebRequest result : ProtocolError : HTTP/1.1 404 Not Found
    ResponseCode : 404, Method : GET
    url : jar:file://!/assets/aa/settings.json

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.