Search Issue Tracker

Active

Votes

31

Found in

2018.3.14f1

2018.4

2019.1

2019.2

2019.3

Issue ID

1153358

Regression

No

[Android] Loading assets from AssetBundles takes significantly more time when the project is built as an AAB

Mobile

-

Repro steps:
1. Download "repro_1153358_1930a1" from the link below
2. Switch build target to Android and make sure that "Build App Bundle (Goole Play)" option is checked
3. Build and Run
4. Wait for the game to go to a screen where some characters and pink textures are seen. might need to double click the screen to skip the intro video
5. Check the device log and look for "xxxxxxx.prefab loaded (yyyyyy)" messages
6. Uncheck "Build App Bundle (Goole Play)" and repeat steps 3 - 5

Actual: The time it takes to load the assets when the project is built as an aab is significantly longer

Reproducible with: 2018.4.1f1, 2019.1.5f1, 2019.2.0b5, 2019.3.0a1

Tested and reproduced on these devices:
VLNQA00013, Samsung Galaxy S6 edge+ (SM-G928F), Android 7.0, CPU: Exynos 7 Octa 7420, GPU: Mali-T760
VLNQA00124, Google Pixel 2 XL (Pixel 2 XL), Android 9, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540
VLNQA00262, Sony Xperia XZ Premium (G8141), Android 9, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540
VLNQA00015, Samsung Galaxy Note8 (SM-N950W), Android 8.0.0, CPU: Snapdragon 835 MSM8998, GPU: Adreno (TM) 540

Notes:
- Asset compression method and scripting backend have no influence on this behavior
- This issue doesn't reproduce with just loading an enormous amount of assets
- This issue doesn't reproduce with just loading the exact same assets that are troublesome

Comments (6)

  1. Ee4a2d27fc6899016c3357eaab991732?d=mm

    Unity_User_2

    Aug 15, 2019 09:04

    Unity 2019.2: problem with all StreamingAssets files which have uppercase letter in their path (relative to StreamingAssets).
    //Directly in StreamingAssets folder or in a subfolder does not matter.

  2. 3af9c28e60b7ed5672d161ca292f57bd?d=mm

    imaginalis

    Aug 10, 2019 14:42

    Will bundletool be updated in Unity 2018.4 as well soon?

  3. 3af9c28e60b7ed5672d161ca292f57bd?d=mm

    imaginalis

    Jul 31, 2019 11:46

    Just tested it on 2019.2 that was released yesterday and it seems to work fine now. I saw in the changelog that bundletool was updated so that's what probably fixed it (at least for my case).

  4. 3af9c28e60b7ed5672d161ca292f57bd?d=mm

    imaginalis

    Jul 26, 2019 07:13

    For us it's loading data from Asset Bundles slower only with LZ4 compression used for Asset Bundles. While using LZMA it works normally. However LZMA Asset Bundles take a lot of time to load, like 10s so that's not an option as well.

  5. 3af9c28e60b7ed5672d161ca292f57bd?d=mm

    imaginalis

    Jul 25, 2019 14:58

    Any progress on this one? For us this makes AAB unusable basically for any project. We really need this fixed.

  6. 3a05df76a1ddb90783ea2113ecb22084?d=mm

    lovelysidhu

    Jul 21, 2019 13:12

    Hii there,

    I have same problem please help me.

    Regards,

    Lovely Sidhu

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.