Search Issue Tracker

Fixed in 2019.2.X

Votes

0

Found in

2019.2.0a5

Issue ID

1126919

Regression

Yes

[Android] Duplicate plugins with the same names prevent from exporting a project to Android

Android

-

Errors related to duplicate plugins with same names thrown in the console which prevents from exporting a project to Android.

Steps to repro:
1. Create a new project
2. File > Build Settings > Android > Switch Platform
3. Check "Export Project" in the Build Settings
4. Click "Export" and select a folder

Actual Result:
Unable to export project for Android due to "Found plugins with same names, and . Delete the one of the duplicate plugins" errors

Expected Result:
Project exports to android without any failure

Reproducible on:
2019.2.0a5

working Fine on:
2019.2.0a4, 2019.1.0b3

Environment:
Occurs only on MacOS

Note: Refer attached editor.log

Stack Trace:
Found plugins with same names, and . Delete the one of the duplicate plugins.
UnityEditor.AndroidPluginImporterExtension:CheckFileCollisions(String)
UnityEditorInternal.PluginsHelper:CheckFileCollisions(BuildTarget) (at /Users/builduser/buildslave/unity/build/Editor/Mono/Plugins/PluginsHelper.cs:25)
UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr)

  1. Response avatar

    Resolution Note (fix version 2019.2):

    The issue is Resolved(fixed) in Unity Version 2019.2.10f1 (76f4e131b7cd), Hence closing it.

Comments (17)

  1. 323dadfa82e51293d6e233340121c178?d=mm

    Betoso

    Aug 15, 2019 19:10

    I solved the issue. It looks like that the folder NDK in 2019.2.0.f1 doen´t contains an important file and it generates that compilation issues. I downloaded the previous version of Unity 2019.1.14f1 and i have copied the folder NDK in that version. Later i have deleted the NDK folder in the 2019.2.0.f1 and pasting the NDK of Unity2019.1.14f1 it works fine. I hope that it helps all you.

    Cheers

  2. 323dadfa82e51293d6e233340121c178?d=mm

    Betoso

    Aug 15, 2019 17:52

    I Updated to 2019.2.0f1 and i have the same issue. The issue is not fixed.

  3. 3af9c19c0a3356f8c56abb961297a741?d=mm

    krakostzakos

    Aug 13, 2019 06:19

    I also upgraded to 2019.2.0f1 and now I get the same error as above: " Found plugins with same names, and . " In the error message there is only an empty string for the plugin name. So I don't know which plugin is causing the error.

  4. 09703dd3cf8180e0a52b4f03c48ac32d?d=mm

    nekomeshi312

    Aug 09, 2019 20:55

    Yes, me too on 2019.2.0f1. How can I fix it?

  5. F5e989b1fcde46ec9b68dc31fa79fabf?d=mm

    BeringelaUnity

    Aug 06, 2019 14:12

    me too, same issue with 2019.2.0f1

    unfortunately this issue is marked as fixed, so I don't think anyone will be seeing it or fixing it

  6. D5203e2f4fab04aa285ab748d7f5bd82?d=mm

    eyeskills

    Jul 31, 2019 12:49

    This is still broken in 2019.2.0f1

  7. B5017fd52b8efde555b09c4519674ffc?d=mm

    Khafra

    Jul 31, 2019 02:28

    I'm still getting this in a the 2019.2.0f1

    I upgraded a project from 2019.1.9, I now get the errors above. It does not list the plugin so I cannot find the duplicate.

Add comment

Log in to post comment

All about bugs

View bugs we have successfully reproduced, and vote for the bugs you want to see fixed most urgently.